Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Can't Install Linux Mint 19.2 on my Laptop
Okay so I have a 2016 Asus X540SA 15.6 inch Laptop with 4GB of RAM and a Quad Core CPU and I seem to can't install anything newer than

- Kernels: 4.13+
- Ubuntu Base: 18.04

At that it freezes upon wake after Sleep/Hibernation and I tried "nomodeset" but it renders my touchpad useless and I get low resolution. I know what's going
on but its weird plus ever since the Spectre & Meltdown patches, my Laptop can't stand the newer kernels/distros (IT LOCKS UP SOLID) such as Linux Mint 19.2... Linux Mint 19.1 runs on my All-in-One Desktop without major issues but my Laptop is on LM 18.3 -- I tried a BIOS Update on my Laptop and no dice.

nomodeset does not work -- it depends on the BIOS version cause my AIO runs the latest kernels no issue there so its gotta be a BIOS issue then.
(08-03-2019, 03:02 PM)Khyree Holmes Wrote: At that it freezes upon wake after Sleep/Hibernation [...]

How well "Sleep" and "Hibernation" work with Linux depends on your hardware. It is basically gambling at this point. Either the firmware of your device supports it or you are out of luck. It tends to work better with BIOS than with UEFI, but that is just my observation.
I also had problems with Sleep back in Windows , so it may be a hardware bios issue. I would just set it to shutdown on closing the lid.
Dos 3.2 to Win 10.
Main - Cinnamon 19.2
   Resistance Is Not Futile!
       It's voltage divided by current

Forum Jump:

Users browsing this thread: 1 Guest(s)