Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] USB WiFi dongle rtl8821CU heartache
#1
Hello everyone! 

  So, I just bought this USB WiFi dongle off of Amazon.com, and I'm having the hardest time using it. It doesn't just work when I plug it in, I have to install the drivers they provided (the company) by hand, which is horrific, as I'm still fresh to all of this.
   Needless to say, that it isn't working yet lol. Well, here's what I've done so far:
   I got into the files and found the `install.sh` file, and then proceeded to chmod it. After chmoding it, i executed it by using ./install.sh. It starts to run in the terminal, and then presents this: https://pasteboard.co/IpMP0k7.png ( I would have just inserted the image but it showed up as broken for some reason).

 It asks for my password to "make clean". After giving my password, it says my password was wrong or "authentication failure".

   I'm at a huge loss right now, because the computer I am trying to install this on doesn't have WiFi built in, and I have to run a USB tether solution so that I can post this from it, and that tethering solution only works less than half of the time, idk why.
   So, if anyone has any idea whats going on, I would be in your debt if you helped me.
    
  Kind regards, 
    At dps

EDIT: HERE IS THE SOLUTION

Code:
#Step 1: Clone brektrou repository

mkdir -p ~/build
cd ~/build
git clone https://github.com/brektrou/rtl8821CU.git

#Step 2: Build and install

cd ~/build/rtl8821CU
make
sudo make install

#Step 3: Check installed driver

ls /lib/modules/$(uname -r)/kernel/drivers/net/wireless/realtek/rtl8821cu

#This worked PERFECTLY!
[Image: IplgSBz.png]
Reply
#2
I am guessing that it is asking not for your password, but the root password. Ubuntu by default does not have a root password, but you can add one with the following commands:

Code:
sudo su
passwd
exit

Now you can try running the script again and use the newly created root password.

Keep in mind that the root password is disabled for a reason, so you migh want to disable it again afterwards.
My website - My git repos

"Things are only impossible until they’re not." - Captain Jean-Luc Picard
Reply
#3
(07-26-2019, 09:07 PM)leon.p Wrote: I am guessing that it is asking not for your password, but the root password. Ubuntu by default does not have a root password, but you can add one with the following commands:

Code:
sudo su
passwd
exit

Now you can try running the script again and use the newly created root password.

Keep in mind that the root password is disabled for a reason, so you migh want to disable it again afterwards.


So, you may be right on that one, but I didn't end up trying that. I did however, figure out how to get it to work. I'm thinking that for some reason, the drivers that came on the CD that they sent with the product (or maybe the scripts they created even) were corrupted, or not optimized for my specific kernel or something, because I ended up trying it under "sudo su", and it passed that "authentication" error, but then got stuck on something about "directory not found", or something... I can't remember exactly.
  After doing some fairly in-depth Googling, I came across a few different ways to go about getting this thing to work (and I think this solution, given you find the correct source for the specific driver your device will need, may work for a LOT of other things), I'll edit my post with the solution!
[Image: IplgSBz.png]
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)