Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
logout shutdown sounds
#1
Running Linux Mint 19.1 on a Lenovo T430 Laptop.

Is there an easy way to enable logout, shutdown sounds?  I got the login sound working by putting code in startup applications and it works fine.  Cannot find an easy way to enable logout, shutdown sounds though.  Looked online for an answer but it's not at all understanding to me.  They say it's Pulse Audio thats causing the problem???  Anyone have an easy answer?

Thanks
Rich.  Huh
Reply
#2
Well I am on Mint 18.3 and if I want to change the sound files I just go the the main menu and in the search bar at the top of the menu I type "sound" and the sound app show's up and I open it, then I go to "Sound Effects" and they are all listed and you can change what is listed to your heart's content... Big Grin

The files are kept in the system folder under, "/usr/share/sounds/???" Some of the directories are easy to spot and others are theme names. I just have a folder in my /Home folder called "Sounds" "/home/your-name/sound and store the sounds that I have collected over the years there and just select the sound that I want to use from there.

Hope this helps... Good Luck!  Smile
**********************************************************
Taglines of the Day:
Today is the tomorrow you worried about yesterday.  Huh 

Everybody remember where we parked. - Kirk

To Boldly Go Where No BBS Has Gone Before. USS Stargazer BBS, Sheridan In.
Reply
#3
I cannot find the menu options you describe.  I am running Linux Mint 19.1.  According to info from the net, pulse audio is having some kind of problem which I don't quite undersatnd how to fix.

Thank you
Rich
Reply
#4
To get the menu just right click the speaker icon in the bar at the bottom of your desktop and choose preferences, it's the first tab in that window.
Reply
#5
(06-01-2019, 01:26 PM)rjs1943 Wrote: I cannot find the menu options you describe.  I am running Linux Mint 19.1.  According to info from the net, pulse audio is having some kind of problem which I don't quite understand how to fix.

Thank you
Rich

Well Rich,
I downloaded 19.1 Mate the other day and installed it into a Virtual  Machine. I see your dalema it it is Mate.... The process I was describing will not work here it is for Mint Cinnamon 18.3...
I am sad to say have no idea how to help. Sorry I did not know that they changed it that much, what a bummer!

That is the worst "preference panel" I have ever seen... Once again, sorry I was no help!  Sad Sad
**********************************************************
Taglines of the Day:
Today is the tomorrow you worried about yesterday.  Huh 

Everybody remember where we parked. - Kirk

To Boldly Go Where No BBS Has Gone Before. USS Stargazer BBS, Sheridan In.
Reply
#6
(06-01-2019, 01:26 PM)rjs1943 Wrote: I cannot find the menu options you describe.  I am running Linux Mint 19.1.  According to info from the net, pulse audio is having some kind of problem which I don't quite undersatnd how to fix.

Thank you
Rich

Ok, let me ask you this. what version of mint do you have? Cinnamon, Mate?
I had Mate loaded in a VM and it has no setting that you can change.

I downloaded a new copy of 19.1 of Cinnamon and installed it in a VM and it has the same menu as 18.3...

1.Go to the Menu on the bottom left and click on it.

2. Just type "Sound" without the quoits... You should see the word "Sound" in the "Search Bar" at the top of the Main Menu,
Now on the top right of the Main Menu you should see "Sound with a Icon that looks like a speaker". 

3. Either press the Enter Key or Click on the Sound link and the Sound Setting Menu should open...

4. Go to the "Sound" Tab and you will see all the files that can be changed. Now as in my first post you can now change them to anything you want....


Now If you are running anything other that Cinnamon, I can not help with that.
I do know that "Mate's" sound preferences are crap you can't change anything and that is all I know about that...  Sad

I am using Mint 18.3 Cinnamon, I may have not stated that in my first post... Sorry...
Good luck Shy
**********************************************************
Taglines of the Day:
Today is the tomorrow you worried about yesterday.  Huh 

Everybody remember where we parked. - Kirk

To Boldly Go Where No BBS Has Gone Before. USS Stargazer BBS, Sheridan In.
Reply
#7
Thank you all for responding.

  I think I'll just wait for a "fix" to come along and try it again.  Right now I'm satisfied with just the login sound on Linux Mint MATE 19.1 on a Lenovo T430 laptop, which is what I'm currently running on My machine.  Everything else is running great.  Don't really want/need to change distributions at this time.  If I get another laptop or maybe I'll put cinnamon on a Virtual Drive and try it there as an experiment.  Only thing, my SSD drive is only 180GB in size and I back up everything onto a 1TB external HDD..  I don't think thats abig enough SSD, What do you guys think??

Again Thanks to all:
Rich
Reply
#8
(06-02-2019, 01:52 PM)rjs1943 Wrote: Thank you all for responding.

  I think I'll just wait for a "fix" to come along and try it again.  Right now I'm satisfied with just the login sound on Linux Mint MATE 19.1 on a Lenovo T430 laptop, which is what I'm currently running on My machine.  Everything else is running great.  Don't really want/need to change distributions at this time.  If I get another laptop or maybe I'll put cinnamon on a Virtual Drive and try it there as an experiment.  Only thing, my SSD drive is only 180GB in size and I back up everything onto a 1TB external HDD..  I don't think thats abig enough SSD, What do you guys think??

Again Thanks to all:
Rich

Your welcome! Don't get discouraged with the issue.
It will work out... Like I said Mate is a great distro and I have used it on hardware and in a VM and the sounds are "theme" related and are not changed easily. Although I have changed a WAV file to a ogg file and replaced it with the same name in the theme folder and it worked that way. You have to be "root" to change the files, I just renamed the file xxxxx.xxx.old, where x's are the name.
Hell give that a try...lol
If you have usb 3.0 on the laptop and you have another usb drive, you can install Cinnamon on the external usb drive and boot to the usb drive and run it that way. I have done this with a drive and a usb 64 gig stick... USB 2.0 does work but a little slow...
Have fun buddy and don't sweat the little stuff!  Big Grin Big Grin Big Grin
Take care! Later
**********************************************************
Taglines of the Day:
Today is the tomorrow you worried about yesterday.  Huh 

Everybody remember where we parked. - Kirk

To Boldly Go Where No BBS Has Gone Before. USS Stargazer BBS, Sheridan In.
Reply
#9
Thank you all for the good informatiom.  I'll keep an eye out for a possible fix. Smile
Reply
#10
(05-31-2019, 02:28 PM)rjs1943 Wrote: Running Linux Mint 19.1 on a Lenovo T430 Laptop.

Is there an easy way to enable logout, shutdown sounds?  I got the login sound working by putting code in startup applications and it works fine.  Cannot find an easy way to enable logout, shutdown sounds though.  Looked online for an answer but it's not at all understanding to me.  They say it's Pulse Audio thats causing the problem???  Anyone have an easy answer?

Thanks
Rich.  Huh


I have not noticed the lack of sounds while using Linux until I read your post. Blush  I guess it is because, I have been without Windows for quite some time.  

I do not have any empirical advice for Linux sound themes, so I will not waste your time commenting on the subject.  However, if you are trying to make the user experience more Windows-like with the login and logout sounds you can easily add them to the lightdm configuration.  See the example below.


If you are using XFCE the user-session= entry should already be xfce.  Likewise, for MATE it will already be set for mate. You need to add the session-setup-script and session-cleanup-script entries.


$ cd /etc/lightdm/lightdm.conf.d

$
$ cat 70-linuxmint.conf 

[SeatDefaults]
user-session=mate
session-setup-script=/usr/local/bin/play_login
session-cleanup-script=/usr/local/bin/play_logout

$


$ cd /usr/local/bin
$
$ ls -l play* 

-r-xr-xr-x 1 root root 73 Jun 12 22:22 play_login
-r-xr-xr-x 1 root root 75 Jun 12 22:23 play_logout

$ cat play_login
#!/bin/bash

/usr/bin/aplay -q /usr/share/sounds/linuxmint-login.wav  &

$ cat play_logout
#!/bin/bash 

/usr/bin/aplay -q /usr/share/sounds/linuxmint-logout.wav &

$


I have modified the lightdm configuration for other reasons, but it very suitable for your login/logout audible triggers.  I personally do not need sounds, but I can understand for accessibility reasons why some users may require audible themes.  I am sure captions, dictation and text to speech are equally important.  

 
Idea  Give a man a fish, and you feed him for a day. Teach a man to fish, and you feed him for a lifetime.

Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)