Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Server
#18
(06-21-2019, 02:51 AM)bescott9944 Wrote:
(06-20-2019, 09:58 PM)muddy Wrote: OK I loaded another machine with Mint 19 and have installed everything. Only now I get the error:

Samba's testparm returned error 1: Load smb config files from /etc/samba/smb.conf
rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
Error loading services.

What does that mean and how can I fix it?

I'm not sure what is going on here. The "testpram" must have some kind of read limit for the file and it is asking you to increase the buffer size maybe? Not sure...

Did you install Samba?
When you install Mint it does not install the full "samba" package, just the token files to kinda make it work.
I have found that I needed to install the full package to get it working correctly...
Enter this command in a "terminal"

Code:
sudo apt install samba
 Now press the "enter key"

If you get as a return message that Samba is installed, it should ask if you want to reinstall it and answer it with a "(Y) or (Yes)" to reinstall and see what happens from there.

Or

You get a bunch of print out and wants to know if you want to install the "samba" packages.. From there answer "Y" for yes and let it install the packages....

Apparently there is something of samba installed by the Error output you got... If there was not, the  "samba testpram" command would tell you that samba is not installed and then give you the command to install it...

Not sure what is going on... You can remove samba and try to reinstall it and see what happens, maybe there was a foobar somewhere... Do this.. Enter this command in a "terminal"

Code:
sudo autoremove samba
Hit "Enter Key" and answer "Y"...
Then reinstall it and see if that fixes the issue... Not sure, just saying, can't hurt...

Also check and make sure that the /etc/samba/smb.conf  is there?

BTW have you edited the "smb.conf" in any way?

Go to my 2nd post, I posted my smb.conf in this thread. All you have to do is copy and paste the text into a new smb.conf that you can create, it is just a plain text file. Then with "SUDO" you can rename the old smb.conf file in the /etc/samba dir. to smb.conf.old and copy the new smb.conf file that you created to the /etc/samba folder.

You might want to edit the "Workgroup" I use "starfleet" as my workgroup name. lol

To do this in a GUI. In NEMO file manager, go to the file tree and select the label "File System", "Right Click' the mouse in a blank area, a menu will popup and select "Open as ROOT", enter your "Root Password" and you are in ROOT mode for the whole system... "BE WARNED THAT ANYTHING YOU DO FROM HERE IS  AS ROOT!!!!! YOU CAN HOSE THE SYSTEM...."

Always OPEN a file and save a "Copy" as (".old"), then edit file, Always have a back-up copy!!!!

Just go click to the /etc folder and find the /samba folder and click on that to open it and you will see a few files and one of them is a smb.conf... Follow the instructions above and when you are done "Exit" out of that Nemo window....

Reboot and good luck!
Should work... Simple as pie! or is that Easy and Pie! "Right"... Lol

Try these links for setting up "smbpasswd" "groups"
https://askubuntu.com/search?q=samba+passwords
https://askubuntu.com/search?q=setting+up+samba
I fixed my limits problem by adding this:

* - nofile 16384 to my /etc/security/limits.conf file

However I am still getting this:

Samba's testparm returned error 1: Load smb config files from /etc/samba/smb.conf

Error loading services.

When I tried to remove samba I get this:

phillip@3847:~$ sudo autoremove samba
[sudo] password for phillip:     
sudo: autoremove: command not found
phillip@3847:~$ 

So I'm not sure where the problem lies.
Reply


Messages In This Thread
Server - by muddy - 05-28-2019, 11:18 PM
RE: Server - by spudnuts - 05-29-2019, 07:11 PM
RE: Server - by muddy - 05-30-2019, 08:46 AM
RE: Server - by spudnuts - 05-31-2019, 01:46 AM
RE: Server - by muddy - 06-01-2019, 01:26 PM
RE: Server - by spudnuts - 06-01-2019, 05:47 PM
RE: Server - by muddy - 06-01-2019, 06:06 PM
RE: Server - by spudnuts - 06-02-2019, 07:40 PM
RE: Server - by bescott9944 - 06-03-2019, 12:20 AM
RE: Server - by bescott9944 - 06-02-2019, 06:13 PM
RE: Server - by bescott9944 - 06-02-2019, 07:25 PM
RE: Server - by muddy - 06-02-2019, 08:02 PM
RE: Server - by henrysay - 06-03-2019, 02:12 AM
RE: Server - by muddy - 06-03-2019, 12:42 PM
RE: Server - by bescott9944 - 06-03-2019, 07:16 PM
RE: Server - by muddy - 06-20-2019, 09:58 PM
RE: Server - by bescott9944 - 06-21-2019, 02:51 AM
RE: Server - by muddy - 06-21-2019, 04:44 AM
RE: Server - by bescott9944 - 06-21-2019, 05:13 AM
RE: Server - by muddy - 06-21-2019, 05:35 AM
RE: Server - by muddy - 06-21-2019, 11:37 AM
RE: Server - by bescott9944 - 06-21-2019, 01:09 PM
RE: Server - by muddy - 06-23-2019, 01:13 AM
RE: Server - by bescott9944 - 06-25-2019, 05:14 PM
RE: Server - by muddy - 06-25-2019, 11:43 PM
RE: Server - by bescott9944 - 06-26-2019, 02:43 AM
RE: Server - by bescott9944 - 06-26-2019, 10:17 PM
RE: Server - by muddy - 07-04-2019, 10:16 AM
RE: Server - by muddy - 07-05-2019, 12:36 AM
RE: Server <SOLVED> - by muddy - 07-05-2019, 06:32 PM
RE: Server <SOLVED> - by bescott9944 - 07-10-2019, 02:08 AM
RE: Server - by dps - 07-26-2019, 04:22 PM
RE: Server - by johnsmith101 - 04-21-2020, 08:04 PM

Forum Jump:


Users browsing this thread: 1 Guest(s)