Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Server
#11
Most excellent replies! Thank you! I have spent the better part of this weekend trying to make it work and have yet to succeed. I almost just gave up, however, with the addition of the latest round of replies I'm going to have a go again. Probably won't be able to do much for a couple of weeks due to some obligations I have outside of this project but I will let ya'll know how it is going when I do start again.

Thank all of you SO much!
Reply
#12
(06-02-2019, 07:40 PM)spudnuts Wrote:
(06-01-2019, 06:06 PM)muddy Wrote:
(06-01-2019, 05:47 PM)spudnuts Wrote: Yes it is permissions and this line comes up if you are in the wrong spot to make the change "The permissions of "Elements" could not be determined.".

The permissions for the drive need to be set to the person you have listed as the forced user in smbshared.conf.

This is one of those cases where it is easier to fix it from the command line if you know how and as an old guy I keep forgetting.


Several posts have info on doing it and also Joe has a couple videos on permissions.

I found this....
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
/dev/mapper/mint--vg-root /               ext4    errors=remount-ro 0       1
# /boot was on /dev/sda1 during installation
UUID=84852069-a27b-4d09-8707-d7844bfd9707 /boot           ext2    defaults        0       2
/dev/mapper/mint--vg-swap_1 none            swap    sw              0       0
LABEL=Elements /mnt/Elements auto nosuid,nodev,nofail,x-gvfs-show 0 0
LABEL=HP\040Launcher /mnt/HP\040Launcher auto nosuid,nodev,nofail,noauto 0 0
LABEL=HP /mnt/HP auto nosuid,nodev,nofail,x-gvfs-show 0 0

But I'm not sure what it means and have been scared to fool with it.

That is your fstab file it just tells linux how and where to mount drives when it starts up, looking at it this part is what was written when you installed linux initially,

# <file system> <mount point>   <type>  <options>       <dump>  <pass>
/dev/mapper/mint--vg-root /               ext4    errors=remount-ro 0       1
# /boot was on /dev/sda1 during installation
UUID=84852069-a27b-4d09-8707-d7844bfd9707 /boot           ext2    defaults        0       2
/dev/mapper/mint--vg-swap_1 none            swap    sw              0       0


and this part was when you told it to automount additional partitions,

LABEL=Elements /mnt/Elements auto nosuid,nodev,nofail,x-gvfs-show 0 0
LABEL=HP\040Launcher /mnt/HP\040Launcher auto nosuid,nodev,nofail,noauto 0 0
LABEL=HP /mnt/HP auto nosuid,nodev,nofail,x-gvfs-show 0 0


the first section is by UUID the second by LABEL and there are other ways to mount them also that have pros and cons for mounting options, but as you can see the file can use multiple formats within a single file.
As for fooling with it, unless it's not mounting stuff you want it to there is no reason to do so.



It's usually something dumb so I'm going to ask are you trying to fix the permissions from the machine that is mounting the drives or from a different one?


Thanks Spudnuts for the explanation, that is what I thought it was... Big Grin

Quote:It's usually something dumb so I'm going to ask are you trying to fix the permissions from the machine that is mounting the drives or from a different one?

Wow! That is a good question...
**********************************************************
Taglines of the Day:
Today is the tomorrow you worried about yesterday.  Huh 

Everybody remember where we parked. - Kirk

To Boldly Go Where No BBS Has Gone Before. USS Stargazer BBS, Sheridan In.
Reply
#13
I have now changed all my machines except one over from Windows to Linux. Well everything but my wife's laptop and there is no way I'm suggesting that to her. <Audacity Find My iPhone Origin My main machine is running Mint and my laptop is running Ubuntu 18.04. I have a Dell Latitude E6400 with four megs of ram that I use as a Plex server currently running Windows and I want to install some kind of Linux server that I can access from my home network (and from outside my network if it is easy to do). I currently am using a Raspberry Pi as a sort of semi server but I don't really like the way it works right now. It has nothing to do with my Plex set up. I won't be sharing Plex much if at all to any outside users except for myself and even then it will be used for streaming music 99.9% of the time so my needs are simple.
Reply
#14
I realized I didn't answer a few questions....

1. So if I understand the post correctly, You want to make a "Media Center"...?
Yes, that is my primary objective. Although I will be keeping various files on the drives as well.

2. What is going to be the Media Center? The Windows, Plex system, which is Dell Latitude E6400 Laptop right?
Plex is what I will be running and it is a Latitude E6400 desktop with 6GB of RAM. I can post spcs if needed.

3. I assume the Element and HP drives are USB external drives right? "Watch this video; https://www.youtube.com/watch?v=AeR8Rk5LwWU&t=809s it will explain what to do."

Yes they are. They load rather slowly due mainly to the amount of data on the drives but I can live with that I think.

Finally...
It's usually something dumb so I'm going to ask are you trying to fix the permissions from the machine that is mounting the drives or from a different one?

I am trying to fix all of this from the machine where they are mounted.
Reply
#15
(06-03-2019, 12:42 PM)muddy Wrote: I realized I didn't answer a few questions....

1. So if I understand the post correctly, You want to make a "Media Center"...?
Yes, that is my primary objective. Although I will be keeping various files on the drives as well.

* Great! It is a great project and worth the time and fun you will have later!

2. What is going to be the Media Center? The Windows, Plex system, which is Dell Latitude E6400 Laptop right?
Plex is what I will be running and it is a Latitude E6400 desktop with 6GB of RAM. I can post spcs if needed.

* Sorry I thought laptop as my E6400 is a laptop...  Smile

3. I assume the Element and HP drives are USB external drives right? "Watch this video; https://www.youtube.com/watch?v=AeR8Rk5LwWU&t=809s it will explain what to do."

Yes they are. They load rather slowly due mainly to the amount of data on the drives but I can live with that I think.

* They do load slow at times, but for this to work you will need to auto load them in your Fstab file when booting so that they will always be available. I know a broken record but watch the video and look at the files I share and you should be able to get all going... I'm 65 and I made it...Lol

Finally...
It's usually something dumb so I'm going to ask are you trying to fix the permissions from the machine that is mounting the drives or from a different one?

I am trying to fix all of this from the machine where they are mounted.

* Well ok it is all fixable and can be done. It is how you setup all loading of drives, folders, sharing said drives/Folders that will make it all work. The main thing is to remember, "if you use "sudo" to complete a task, you are the "root" owner and the only one that can change that setting."
You have to set the "properties/permissions tab" for the drive so anyone can "create and delete" on it do it will all work.

If you format a drive in "gparted" (which means you are the "Root" user because it asks for the Root Password) and then you exit Gparted and try to use the drive as yourself, nothing will work because you are not the "Root" user....
Yes you then have to go back to being the "Root" user and set the "Access" in the "Properties/Permissions tab" so everyone in your group can use the drive... Then it will work for "you"...
Now say it, I know, watch the video....LOL  Big Grin Big Grin Big Grin

Have fun with this project, it is a great learning experience and once it sticks it will not totally go away. BTW, when you add a new hard drive to your system, it is the same fun... Take care my friend... Later!
P.S. I use alot of Joe's as references all the time..
**********************************************************
Taglines of the Day:
Today is the tomorrow you worried about yesterday.  Huh 

Everybody remember where we parked. - Kirk

To Boldly Go Where No BBS Has Gone Before. USS Stargazer BBS, Sheridan In.
Reply
#16
OK I loaded another machine with Mint 19 and have installed everything. Only now I get the error:

Samba's testparm returned error 1: Load smb config files from /etc/samba/smb.conf
rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
Error loading services.

What does that mean and how can I fix it?
Reply
#17
(06-20-2019, 09:58 PM)muddy Wrote: OK I loaded another machine with Mint 19 and have installed everything. Only now I get the error:

Samba's testparm returned error 1: Load smb config files from /etc/samba/smb.conf
rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
Error loading services.

What does that mean and how can I fix it?

I'm not sure what is going on here. The "testpram" must have some kind of read limit for the file and it is asking you to increase the buffer size maybe? Not sure...

Did you install Samba?
When you install Mint it does not install the full "samba" package, just the token files to kinda make it work.
I have found that I needed to install the full package to get it working correctly...
Enter this command in a "terminal"

Code:
sudo apt install samba
 Now press the "enter key"

If you get as a return message that Samba is installed, it should ask if you want to reinstall it and answer it with a "(Y) or (Yes)" to reinstall and see what happens from there.

Or

You get a bunch of print out and wants to know if you want to install the "samba" packages.. From there answer "Y" for yes and let it install the packages....

Apparently there is something of samba installed by the Error output you got... If there was not, the  "samba testpram" command would tell you that samba is not installed and then give you the command to install it...

Not sure what is going on... You can remove samba and try to reinstall it and see what happens, maybe there was a foobar somewhere... Do this.. Enter this command in a "terminal"

Code:
sudo apt autoremove samba
Hit "Enter Key" and answer "Y"...
Then reinstall it and see if that fixes the issue... Not sure, just saying, can't hurt...

Also check and make sure that the /etc/samba/smb.conf  is there?

BTW have you edited the "smb.conf" in any way?

Go to my 2nd post, I posted my smb.conf in this thread. All you have to do is copy and paste the text into a new smb.conf that you can create, it is just a plain text file. Then with "SUDO" you can rename the old smb.conf file in the /etc/samba dir. to smb.conf.old and copy the new smb.conf file that you created to the /etc/samba folder.

You might want to edit the "Workgroup" I use "starfleet" as my workgroup name. lol

To do this in a GUI. In NEMO file manager, go to the file tree and select the label "File System", "Right Click' the mouse in a blank area, a menu will popup and select "Open as ROOT", enter your "Root Password" and you are in ROOT mode for the whole system... "BE WARNED THAT ANYTHING YOU DO FROM HERE IS  AS ROOT!!!!! YOU CAN HOSE THE SYSTEM...."

Always OPEN a file and save a "Copy" as (".old"), then edit file, Always have a back-up copy!!!!

Just go click to the /etc folder and find the /samba folder and click on that to open it and you will see a few files and one of them is a smb.conf... Follow the instructions above and when you are done "Exit" out of that Nemo window....

Reboot and good luck!
Should work... Simple as pie! or is that Easy and Pie! "Right"... Lol

Try these links for setting up "smbpasswd" "groups"
https://askubuntu.com/search?q=samba+passwords
https://askubuntu.com/search?q=setting+up+samba
**********************************************************
Taglines of the Day:
Today is the tomorrow you worried about yesterday.  Huh 

Everybody remember where we parked. - Kirk

To Boldly Go Where No BBS Has Gone Before. USS Stargazer BBS, Sheridan In.
Reply
#18
(06-21-2019, 02:51 AM)bescott9944 Wrote:
(06-20-2019, 09:58 PM)muddy Wrote: OK I loaded another machine with Mint 19 and have installed everything. Only now I get the error:

Samba's testparm returned error 1: Load smb config files from /etc/samba/smb.conf
rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
Error loading services.

What does that mean and how can I fix it?

I'm not sure what is going on here. The "testpram" must have some kind of read limit for the file and it is asking you to increase the buffer size maybe? Not sure...

Did you install Samba?
When you install Mint it does not install the full "samba" package, just the token files to kinda make it work.
I have found that I needed to install the full package to get it working correctly...
Enter this command in a "terminal"

Code:
sudo apt install samba
 Now press the "enter key"

If you get as a return message that Samba is installed, it should ask if you want to reinstall it and answer it with a "(Y) or (Yes)" to reinstall and see what happens from there.

Or

You get a bunch of print out and wants to know if you want to install the "samba" packages.. From there answer "Y" for yes and let it install the packages....

Apparently there is something of samba installed by the Error output you got... If there was not, the  "samba testpram" command would tell you that samba is not installed and then give you the command to install it...

Not sure what is going on... You can remove samba and try to reinstall it and see what happens, maybe there was a foobar somewhere... Do this.. Enter this command in a "terminal"

Code:
sudo autoremove samba
Hit "Enter Key" and answer "Y"...
Then reinstall it and see if that fixes the issue... Not sure, just saying, can't hurt...

Also check and make sure that the /etc/samba/smb.conf  is there?

BTW have you edited the "smb.conf" in any way?

Go to my 2nd post, I posted my smb.conf in this thread. All you have to do is copy and paste the text into a new smb.conf that you can create, it is just a plain text file. Then with "SUDO" you can rename the old smb.conf file in the /etc/samba dir. to smb.conf.old and copy the new smb.conf file that you created to the /etc/samba folder.

You might want to edit the "Workgroup" I use "starfleet" as my workgroup name. lol

To do this in a GUI. In NEMO file manager, go to the file tree and select the label "File System", "Right Click' the mouse in a blank area, a menu will popup and select "Open as ROOT", enter your "Root Password" and you are in ROOT mode for the whole system... "BE WARNED THAT ANYTHING YOU DO FROM HERE IS  AS ROOT!!!!! YOU CAN HOSE THE SYSTEM...."

Always OPEN a file and save a "Copy" as (".old"), then edit file, Always have a back-up copy!!!!

Just go click to the /etc folder and find the /samba folder and click on that to open it and you will see a few files and one of them is a smb.conf... Follow the instructions above and when you are done "Exit" out of that Nemo window....

Reboot and good luck!
Should work... Simple as pie! or is that Easy and Pie! "Right"... Lol

Try these links for setting up "smbpasswd" "groups"
https://askubuntu.com/search?q=samba+passwords
https://askubuntu.com/search?q=setting+up+samba
I fixed my limits problem by adding this:

* - nofile 16384 to my /etc/security/limits.conf file

However I am still getting this:

Samba's testparm returned error 1: Load smb config files from /etc/samba/smb.conf

Error loading services.

When I tried to remove samba I get this:

phillip@3847:~$ sudo autoremove samba
[sudo] password for phillip:     
sudo: autoremove: command not found
phillip@3847:~$ 

So I'm not sure where the problem lies.
Reply
#19
Quote:When I tried to remove samba I get this:

phillip@3847:~$ sudo autoremove samba
[sudo] password for phillip:     
sudo: autoremove: command not found
phillip@3847:~$ 

So I'm not sure where the problem lies.


I am sorry, I foobared the command... My bad... Sorry!!!
Here is the correct command...
Code:
sudo apt autoremove samba
Then press enter...

Also I fixed my post! Once again Sorry for the confusion.....
**********************************************************
Taglines of the Day:
Today is the tomorrow you worried about yesterday.  Huh 

Everybody remember where we parked. - Kirk

To Boldly Go Where No BBS Has Gone Before. USS Stargazer BBS, Sheridan In.
Reply
#20
OK I am REALLY close!

This is my smb.conf:
[global]
server string = 3847
workgroup = 3847
client max protocol = NT1
security = user
map to guest = Bad User
name resolve order = bcast host wins
include = /etc/samba/smbshared.conf

This is my smbshared.conf:
[media]
    force user = phillip
    path = /home/3847/media
    writable = yes
    public = yes

[Media Drive]
    force user = phillip
    path = /home/3847/data
    writable = yes
    public = yes


[data]
    force user = phillip
    path = /home/3847/Media Drive
    writable = yes
    public = yes

I am attaching screen shots of what happens.When I try to open any of the drives I get the same no such file message, I'm thinking it is simple whatever it is but I am missing it.


Attached Files
.png   network.png (Size: 195.63 KB / Downloads: 2)
.png   network1.png (Size: 192.41 KB / Downloads: 4)
.png   network2.png (Size: 203.24 KB / Downloads: 2)
.png   network3.png (Size: 205.27 KB / Downloads: 2)
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)