Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
How To Make Elementary OS or Ubuntu Boot Faster
#1
If your Elementary OS or other Ubuntu based system (16.04) is taking a long time to boot up all you need to do is change the seconds of the DefaultTimeoutStart.

BEFORE hand cp the sudo cp /etc/systemd/system.conf /etc/systemd/system.conf.bak to make a back up.

To do so edit the /etc/systemd/system.conf with your favorite text editor with elevated privileges.

Move to the two lines in the file that say:
Code:
#DefaultTimeoutStartSec=90s

Un-comment the string and change =90 to 10 seconds like so:
Code:
DefaultTimeoutStartSec=10s

Reboot:-

Your system should boot a lot faster:-
A morning without coffee is like something without something else.
Reply
#2
Your post is unreadable. The print is a very light gray.

Richard
Reply
#3
Glad I'm not the only one. For a minute I thought I was going blind.
Cliff Coggin
Mint 18.3
Reply
#4
(05-27-2019, 09:31 PM)Alexzee Wrote: Move to the two lines in the file that say:
Code:
#DefaultTimeoutStartSec=90s
Un-comment the string and change =90 to 10 seconds like so:
Code:
DefaultTimeoutStartSec=10s

The timeout should only happen if something went wrong
and systemd is waiting on a process to start or fail.
In other words, if you are constantly having timeouts,
there is something wrong. Shortening the timeout only
hides the immediate symptons.


Off topic: Try to not change the colours or font size
when writing a post. People use different themes (dark
vs. bright) and your post could be unreadable if you
colour it to fit a specific theme. By default the colour
will be changed to fit the theme. Also leave the font
size as is, as it is much nicer to read a post when all
text in the thread is uniform.
My website - My git repos

"Things are only impossible until they’re not." - Captain Jean-Luc Picard
Reply
#5
(05-27-2019, 11:03 PM)Richard Wrote: Your post is unreadable. The print is a very light gray.

Richard
Ctrl+A should will do it  Smile
Brian36
Reply
#6
(06-01-2019, 11:50 AM)Brian36 Wrote: Ctrl+A should will do it  Smile
Brian36

We shouldn't have to...
Reply
#7
Can you see the text now?
A morning without coffee is like something without something else.
Reply
#8
No. Still can't see it.
Cliff Coggin
Mint 18.3
Reply
#9
(06-11-2019, 11:34 AM)cliffcoggin Wrote: No. Still can't see it.

I turned off Dark Reader.

How's it now?
A morning without coffee is like something without something else.
Reply
#10
(05-28-2019, 02:07 PM)leon.p Wrote:
(05-27-2019, 09:31 PM)Alexzee Wrote: Move to the two lines in the file that say:
Code:
#DefaultTimeoutStartSec=90s
Un-comment the string and change =90 to 10 seconds like so:
Code:
DefaultTimeoutStartSec=10s

The timeout should only happen if something went wrong
and systemd is waiting on a process to start or fail.
In other words, if you are constantly having timeouts,
there is something wrong <-> Dafont Showbox Adam4adam . Shortening the timeout only
hides the immediate symptons.


Off topic: Try to not change the colours or font size
when writing a post. People use different themes (dark
vs. bright) and your post could be unreadable if you
colour it to fit a specific theme. By default the colour
will be changed to fit the theme. Also leave the font
size as is, as it is much nicer to read a post when all
text in the thread is uniform.

Your post is unreadable. The print is a very light gray.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)