Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Mounting virtual optical drive in LXDE (Solved)
I have the LXDE desktop up and running in an Arch Linux virtual machine in Virtual Box 6.0.5. I am trying to install the guest additions.

The first problem is that when I go to "Devices" in the LXDE desktop and insert the guest .iso file, it does not autorun. OK, no problem there, but neither does the optical drive appear in the file system, plus there is no "media" directory in the file system. But when I go to the Virtual Box GUI and look in the "settings", it shows that the guest.iso file has indeed been inserted in the virtual optical drive.

How do I mount the virtual optical drive in Arch? I have tried the command: "mount /dev/sr0 /media/cdrom" but that is no good.

I used "mkdir /media/cdrom" to creat the needed directories and then ran "mount /dev/cdrom /media/cdrom". The guest .iso image is now there, but I cannot get it to run. I double click on the file and when it tells me the file is execuble and asks if I want to run it, I say "yes" but nothing happens.

A second question is that, even if I get it to run, the Arch wiki says "do not install the guest additions from the .iso file that is installed with Virtual Box in your host system, but use the guest additions from the Arch repository. The problem with that is, due to the recent Ubuntu kernel incompatibility, I am having to run VBox 6.0.5 (a test edition), and the guest additions in the Arch repository is 6.0.4. That won't work.

The wiki says I can reconfigure the 6.0.5 guest.iso so it will work in Arch by running the command " rcvboxdrv" as root. When I run that command I get "command not found".
It got solved as I continued doing my homework. For those of you who may be interested in building an Arch machine in Virtual Box, I will explain:

I am running three Arch virtual machines. One headless, one with the Budgie desktop, one with the LXDE desktop. In either of the desktops, when I went to "Device" "Insert Guest .iso in virtual drive", the drive would not appear in the file system. But when I went to the VBox GUI, and looked in storage, it showed it as loaded.

What I did was to shut down Arch, remove the Guest .iso from the drive, then boot up Arch in terminal mode (not running the desktop) and create the directories. /media/cdrom in root.
Then in the VBox GUI I inserted the Guest .iso in the optical drive and ran the following command:
"sudo mount /dev/cdrom /media/cdrom"
and when I changed to the /media/cdrom directory and ran the command "ls", it showed the Guest .iso files were now there.

I ran: "sudo ./" and I'll be damned: Guest Additions installed and when I opened the desktop, the desktop went to full screen and showed the shared host folder.

If I may just chime in on this.

Arch and Gentoo do not use /media, but use /run/media. I don't know why I also have /media, but external media always gets mounted in /run/media/$USER (in my case, /run/media/sandy). That was true when I ran Antergos (Arch derivative) and is still true when running Gentoo. /media is used by Debian derivatives though, not sure about other distro families.
Name: Sandy Vujaković
Laptop: Dell Inspiron 3793 (17", i5)
OS: Ubuntu Groovy Gorilla

Forum Jump:

Users browsing this thread: 1 Guest(s)