Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Installing desktops in Arch (solved)
#1
I have made a good installation of Arch as a virtual machine in Virtual Box. It is fast and works perfectly. Until I try to install a desktop.

I have spent hours and hours studying the Arch Wikis and the Arch forum. I have installed three different desktops: LXDE, Budgie, and Gnome. Multiple times each. The only one that will install and open without crashing the machine is Gnome, and after Gnome opens, the applications are glacially slow. And I mean really slow. It takes five minutes to change directories in the file manager. That kind of slow.

Here is one path I went down today. This is a post from the Arch forum:

1. After installing the base system, create a user with all required groups, including wheel.
2. Reboot and log into your new user.
3. sudo pacman -S lxde (choose whichever packages you want)
4. sudo systemctl enable lxdm
5. Reboot, and lxdm should start - type in your password and boom, you're in lxsession.

I did that exactly, and when I boot up and log in, boom, the black terminal screen freezes.

I have tried to run LXDE from the terminal. I edited the .xinitrc file in my home directory to include "startlxde". When I enter "startx" it freezes.

Has anyone here successfully installed a desktop on Arch? If so, how did you do it?

Richard
Reply
#2
(04-09-2019, 11:35 PM)Richard Wrote: I did that exactly, and when I boot up and log in, boom, the black terminal screen freezes.

I have tried to run LXDE from the terminal. I edited the .xinitrc file in my home directory to include "startlxde". When I enter "startx" it freezes.

That sounds a bit like a video driver issue, as your computer always freezes when you open a graphical environment.
Have you installed the correct driver? Otherwise your CPU might be used to calculate the graphics, which is usually
not a good idea.

Try installing the 'xorg-drivers' meta-package, which should contain the correct drivers for basically any
hardware.
Reply
#3
Leon,

You are my Linux hero. I installed the VMware video driver and LXDE opens right up when I enter "startx".

Richard
Reply
#4
Glad I could help.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)