Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Virtual Box will not open guest systems (Solved)
Following an Ubuntu update three days ago (16.04), I get the following message when I attempt to run a guest system in Virtual Box.

"Kernel driver not installed (rc=-1908)
The VirtualBox Linux kernel driver (vboxdrv) is either not loaded or there is a permission problem with /dev/vboxdrv. Please reinstall the kernel module by executing
as root.
where: suplibOsInit what: 3 VERR_VM_DRIVER_NOT_INSTALLED (-1908) - The support driver is not installed. On linux, open returned ENOENT."

(There is no file: dev/vboxdrv in existence on my system)
When I run '/sbin/vboxconfig' I get this message:

"sudo /sbin/vboxconfig
[sudo] password for raspero: Stopping VirtualBox services. Starting VirtualBox services. Building VirtualBox kernel modules. failed: Look at /var/log/vbox-setup.log to find out what went wrong.
There were problems setting up VirtualBox. To re-start the set-up process, run
as root."

I re-installed Virtual Box, but the problem remains. I looked at the log file as recommended, but it is huge and says nothing I can understand.

Hello Richard
I've had a similar if not the same issue. I solved it by reinstalling Virtualbox package. (not just virtualbox-qt which provides the user interface)

When you reinstalled did you only reinstall virtualbox-qt or virtualbox in its entirety?
If you reinstalled from the software centre then you have most likely only reinstalled virtualbox-qt
The only way to be sure that you have reinstalled virtual in its entirety is to issue the commands if you haven't already.
sudo apt remove virtualbox
sudo apt install virtualbox
If that dosen't work and I have my commands right then this is not is causing the issue.
I ran the apt remove in the terminal and it failed to remove it. I then used synaptic to remove it. I then re-installed it. I have the same problem. There is no /dev/vboxdrv file.

I discovered on the Virtual Box forum that others are having the same problem with the latest Ubuntu kernel. I booted up with the previous kernel and I did not have to do anything. My guest systems boot up fine now. Either Ubuntu will fix the kernel or Oracle will fix Virtual Box. (One hopes.)


Forum Jump:

Users browsing this thread: 1 Guest(s)