Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[semi-solved] Weird issues with home network... [caused by provider]
#1
Ok so this is a weird issue.

Whenever I am using my mothers WiFi, I have connection issues with some applications.
What works is firefox, my mail client, RSS feed reader and the package manager.
The things that don't work include 'ping' and 'w3m' besides litteraly any other application.

At first I thought this was a DNS issue, because my mothers router includes a DNS server.
So for a time I was able to solve this problem by adding the routers IP into my list of DNS servers,
but recently this stopped working (I then removed it and also tried a few other DNS servers, but to no avail).

Using the command 'dig' I found out that DNS resolution works all the time, but I could still not ping any websites
(100% package loss).

I also tried disabling my firewall (ip-tables.service) but this also did not help.

Interestingly, when using tor, I can successfully get a connection ( 'torsocks w3m' works)...

This problem is quite weird, since I did not change lot about the NetworkManager configuration,
besides using a MAC-adress randomizer (I also tried to disable that)
and switching the resolution service to 'resolvconf' (Also tried changing that back).


This problem only ever happens in my mothers WiFi network (I tried resetting the router),
all other networks (even with similar hardware) work fine.


Are there any network guys that know what causes this?
Reply
#2
Have you tried using ping to an IP address instead of a domain?

What I usually do in those spots is:
Arrow Ping localhost
Arrow Ping the routers IP address
Arrow Ping the external DNS server (or just try pining 1.1.1.1)
Arrow Ping google.com

If the ping to the router already fails, I'll be pretty sure that it will be an issue with a local firewall. 
If it fails pining the DNS server, it could be an issue with the router or its firewall.
If it fails when pining Goolge, it could possibly be a DNS issue.
Reply
#3
(10-31-2018, 05:49 PM)wheel Wrote: Have you tried using ping to an IP address instead of a domain?

What I usually do in those spots is:
Arrow Ping localhost
Arrow Ping the routers IP address
Arrow Ping the external DNS server (or just try pining 1.1.1.1)
Arrow Ping google.com

If the ping to the router already fails, I'll be pretty sure that it will be an issue with a local firewall. 
If it fails pining the DNS server, it could be an issue with the router or its firewall.
If it fails when pining Goolge, it could possibly be a DNS issue.

Pinging localhost works.
Pinging the router also works.
Pinging some DNS servers also works (208.67.222.222 208.67.220.220 1.1.1.1 8.8.8.8 8.8.4.4).
Pinging a domain has 100% package loss.

When I manually get the IP adress of a domain using 'dig' and ping it, it works.

What I found out: When I do 'ping debian.org', it resolves into an IP-6 address while using 'dig debian.org' resolves into an IP-4 address. Pinging the first one fails, the second one succeeds.

So maybe the provider does not support IP-6...
(It is a weird provider after all, they send the data through the old TV coax cable)
Reply
#4
(10-31-2018, 09:34 PM)leon.p Wrote: Pinging localhost works.
Pinging the router also works.
Pinging some DNS servers also works (208.67.222.222  208.67.220.220  1.1.1.1  8.8.8.8  8.8.4.4).
Pinging a domain has 100% package loss.

When I manually get the IP adress of a domain using 'dig' and ping it, it works.

What I found out: When I do 'ping debian.org', it resolves into an IP-6 address while using 'dig debian.org' resolves into an IP-4 address. Pinging the first one fails, the second one succeeds.

So maybe the provider does not support IP-6...
(It is a weird provider after all, they send the data through the old TV coax cable)

Do you even have an external IPv4 address? ( https://myip.is/ )

I hope you don't mind if I take a shot in the dark, but this issue sounds extremely familiar to me. 
Afaik, you live in Germany and use provider with a coax-cable based network. This is probably Vodafone (earlier KabelDeutschland). One of my friends had a contract with them and was using the basic (free) router. 
He was also unable to get connected to some specific servers and/or use specific network protocols. (I think he couldn't ping some servers and wasn't able to use a Minecraft server)
As it turned out, his provider wouldn't give him full IPv4 access to the internet. And the router that was included in the contract was a really weird thing. It didn't even come with WiFi support in first place. He had to pay an extra fee to get WiFi enabled on this router.
What he did was to call his provider and kindly asked them to set free full IPv4 support. And surprisingly, they did. For free. I was pretty surprised that a support person even knew what was going on. Seemingly this thing happened more often.
He also bought a FritzBox as his new router. It has way more options to configure. Since Aug 1, 2016 every provider has to allow you to use any privately bought router here in Germany. The FritzBoxes 6490/6590 come with cable support and use the newest firmware.


Obviously, I'm absolutely not sure if this fits your problem. But since it looks pretty much like an issue with your provider, I think there's a chance my shot in the dark could be a hit.
Reply
#5
(10-31-2018, 10:10 PM)wheel Wrote: Do you even have an external IPv4 address? ( https://myip.is/ )

I hope you don't mind if I take a shot in the dark, but this issue sounds extremely familiar to me. 
Afaik, you live in Germany and use provider with a coax-cable based network. This is probably Vodafone (earlier KabelDeutschland). One of my friends had a contract with them and was using the basic (free) router. 
He was also unable to get connected to some specific servers and/or use specific network protocols. (I think he couldn't ping some servers and wasn't able to use a Minecraft server)
As it turned out, his provider wouldn't give him full IPv4 access to the internet. And the router that was included in the contract was a really weird thing. It didn't even come with WiFi support in first place. He had to pay an extra fee to get WiFi enabled on this router.
What he did was to call his provider and kindly asked them to set free full IPv4 support. And surprisingly, they did. For free. I was pretty surprised that a support person even knew what was going on. Seemingly this thing happened more often.
He also bought a FritzBox as his new router. It has way more options to configure. Since Aug 1, 2016 every provider has to allow you to use any privately bought router here in Germany. The FritzBoxes 6490/6590 come with cable support and use the newest firmware.


Obviously, I'm absolutely not sure if this fits your problem. But since it looks pretty much like an issue with your provider, I think there's a chance my shot in the dark could be a hit.

I live in germany, indeed.
And my mother does in fact use Kabel Deutschland / Vodafone, although in this case IP-4 works perfectly fine while IP-6 does not work at all.

Changing the router is possible (the best option would be to get a seperate coax decoder box and connect it to a new router),
but I don't think this would solve the issue: I looked through the webinterface and it does not really seem like there are any blocked features.

For now I am just using tor for all things that wont work,
but the next time I visit my mother I will reconfigure NetworkManager to prefer IP-4.



What really annoys me about this is that the router, which was given to my mother by the provider,
has a build-in DNS service that resolves domains to IP-6 although the provider is seemingly only supporting IP-4.



I am going to mark this as solved now, thanks for your help!
Reply
#6
It makes sense that the network environment of tor helps to pass by whatever blocks a service.
Maybe a VPN would be faster and more secure? Remember that any unencrypted data can be read by other participants in the tor network.

Using another router was just an idea in order to get rid of the weird standard device that Vodafone delivers.

Good luck with fixing this thing. Please keep me up to date. I'm kinda excited about it, since this seems to be kind of a frequent issue.
Reply
#7
(11-01-2018, 12:03 AM)wheel Wrote: It makes sense that the network environment of tor helps to pass by whatever blocks a service.
Maybe a VPN would be faster and more secure? Remember that any unencrypted data can be read by other participants in the tor network.

Using another router was just an idea in order to get rid of the weird standard device that Vodafone delivers.

Good luck with fixing this thing. Please keep me up to date. I'm kinda excited about it, since this seems to be kind of a frequent issue.

In that regard tor is quite similar to the regular net: If it's plain http, everyone can read it.
Luckily almost nothing nowadays uses plain http, even if all you are doing is reading a web comic, it will still use https.

Sadly the only VPN I currently have access to is the one from my university,
which is terribly slow and only allows me to have a direct tunnel to the computer clusters there
(a pretty worthless feature since my departement has an ssh domain...)
Reply
#8
(11-01-2018, 12:03 AM)wheel Wrote: Good luck with fixing this thing. Please keep me up to date. I'm kinda excited about it, since this seems to be kind of a frequent issue.

I found a better workaround than using tor: disabling the IP-6 protocoll.
Code:
sysctl -w net.ipv6.conf.all.disable_ipv6=1
sysctl -w net.ipv6.conf.default.disable_ipv6=1

To enable it again:
Code:
sysctl -w net.ipv6.conf.all.disable_ipv6=0
sysctl -w net.ipv6.conf.default.disable_ipv6=0


The change is immediate and does not require a reboot.


If I remember correctly, NetworkManager has support for hooks,
so you could configure it to run these commands automatically when connection to specific networks.
Reply
#9
(10-31-2018, 09:34 PM)leon.p Wrote: What I found out: When I do 'ping debian.org', it resolves into an IP-6 address while using 'dig debian.org' resolves into an IP-4 address. Pinging the first one fails, the second one succeeds.

Strange, ping always resolves to IPv4 on my laptop.
Name: Sandy Vujaković
Laptop: Dell Inspiron 3793 (17", i5)
OS: Ubuntu Groovy Gorilla
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)