Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Very Slow USB Sticks [SOLVED]
#11
I am not surprised. Those transparent huge pages cause all kinds of issues. In fact many applications like database servers recommend disabling them. I always disable them on CentOS.

You have options. Also it depends some on the distro.

1) sysctl.conf should work fine.

2) You could make an init or systemd unit with either configured to run on start up.

3) You could just execute the command when your user logs on. Joe has shown this in videos although it varies slightly from DE to DE. Still you should have a startup area. The only downside is other user accounts won't be covered unless those get the same changes.
Jeremy (Mr. Server)

* Desktop: Ubuntu MATE
* Windows are for your walls, Apple is for your health, Linux is for your computer
Reply
#12
Great!!!! I like creating systemd unit files... they are fun...

Thanks again,
David
Reply
#13
(08-17-2018, 08:43 PM)cleverwise Wrote: You might have to disable transparent huge pages.  There can be other causes but this is one to try.

Check the status:

Code:
shell> cat /sys/kernel/mm/transparent_hugepage/enabled

You want to see never set.

To change in just runtime (will go back when you reboot)

Code:
shell> echo never > /sys/kernel/mm/transparent_hugepage/enabled

Now check again that it is never.  Then try copying USB.  If something goes wrong just reboot.

Hi Jeremy, I am having similar issues to David. When I ran the "cat" command on that file it, it is set to always.

I tried to run the second command you listed. I got this readout:
Code:
bash: /sys/kernel/mm/transparent_hugepage/enable: Permission denied

I even tried to run it with sudo and got the same result.

I tried to change it in pluma and was able to write it out successfully. But then when I opened it again or ran the "cat" command again, it was still set to always. Do you have any thoughts on how to handle this?

Thank you,
Sal
Reply
#14
While there are multiple ways to handle this I would just go into root for this command:

Code:
shell> sudo su

Enter your user password.  You'll be logged in as root

root@YOUR_HOSTNAME

Now run:


Code:
shell> echo never > /sys/kernel/mm/transparent_hugepage/enabled

Now run to check:

Code:
shell> cat /sys/kernel/mm/transparent_hugepage/enabled

If set to never then type exit to log out of root back to user account.  If not I would still log out of root.
Jeremy (Mr. Server)

* Desktop: Ubuntu MATE
* Windows are for your walls, Apple is for your health, Linux is for your computer
Reply
#15
(06-12-2019, 08:17 PM)cleverwise Wrote: While there are multiple ways to handle this I would just go into root for this command:

Code:
shell> sudo su

Enter your user password.  You'll be logged in as root

root@YOUR_HOSTNAME

Now run:


Code:
shell> echo never > /sys/kernel/mm/transparent_hugepage/enabled

Now run to check:

Code:
shell> cat /sys/kernel/mm/transparent_hugepage/enabled

If set to never then type exit to log out of root back to user account.  If not I would still log out of root.

I tried it and I still get the output:
Code:
always madvise [never]

I copied and pasted the code, so I don't what is going on.
Reply
#16
Never is selected.

The brackets [ ] show what is being used.

So:

always madvise [never]

Means never is selected.  If it read [always] then always is selected.
Jeremy (Mr. Server)

* Desktop: Ubuntu MATE
* Windows are for your walls, Apple is for your health, Linux is for your computer
Reply
#17
(06-13-2019, 02:06 PM)cleverwise Wrote: Never is selected.

The brackets [ ] show what is being used.

So:

always madvise [never]

Means never is selected.  If it read [always] then always is selected.

OK. Thank you. I was reading it backwards. Sorry for the confusion.

Thank you,
Sal
Reply
#18
(06-13-2019, 02:36 PM)sal Wrote:
(06-13-2019, 02:06 PM)cleverwise Wrote: Never is selected.

The brackets [ ] show what is being used.

So:

always madvise [never]

Means never is selected.  If it read [always] then always is selected.

OK. Thank you. I was reading it backwards. Sorry for the confusion.

Thank you,
Sal

Sure.  No worries.  I wasn't confused.  Wink
Jeremy (Mr. Server)

* Desktop: Ubuntu MATE
* Windows are for your walls, Apple is for your health, Linux is for your computer
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)