Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ubuntu18.4.1 and unmet dependencies for kodi
#1
I recently upgraded from 16.4.1 to 18.4.1 and tried to reinstall kodi from the ubuntu repository it failed and displayed message that says '' unable to install kodi: The following packages have unmet dependencies:  I also tried to install from the command line with no success, has anyone else install kodi on ubuntu 18.4.1   thanks for any help? sudo apt install kodi
[sudo] password for joe:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
kodi : Depends: kodi-bin (< 2:17.6+dfsg1-1ubuntu1.1~) but 2:17.6+git20171114.2125-final-0xenial is to be installed
Recommends: kodi-repository-kodi but it is not going to be installed or
kodi-repository
Recommends: kodi-visualization-spectrum but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
Reply
#2
(08-17-2018, 07:25 PM)jwk Wrote: I recently upgraded from 16.4.1 to 18.4.1 and tried to reinstall kodi from the ubuntu repository it failed and displayed message that says '' unable to install kodi: The following packages have unmet dependencies:  I also tried to install from the command line with no success, has anyone else install kodi on ubuntu 18.4.1   thanks for any help?   sudo apt install kodi
[sudo] password for joe:
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
kodi : Depends: kodi-bin (< 2:17.6+dfsg1-1ubuntu1.1~) but 2:17.6+git20171114.2125-final-0xenial is to be installed
       Recommends: kodi-repository-kodi but it is not going to be installed or
                   kodi-repository
       Recommends: kodi-visualization-spectrum but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Did you do an in-place upgrade?  If so, that could be the problem.  I'm running 18.04.1  and i have not had any issues installing Kodi. I used the version directly from synaptic ( ubuntu repos ) since it is the latest version.  Kodi 18 Alpha is available as a snap package in the snap edge repo.  You can open a terminal and type  snap info kodi  for details on that package.  I have been using the stock Ubuntu version of Kodi because i plan on moving to the Snap package when it hits stable.  You can try running  sudo apt-get install -f.  This sometimes can automatically fix dependency errors. But like i said, if you did an in-place upgrade from 16.04 to 18.04 then you may want to do a fresh clean install. in-place upgrades can sometimes make a mess of things.
Reply
#3
He's right, in place upgrades do have a tendency to break repos. Experienced this myself many times.
Reply
#4
thanks guys, yes I did an in place upgrade, I still have kodi on a second hdd running 16.4.1 on the same pc, apart from the version of ubuntu its a mirror of all my data , If I knew what files need changing to get things working it would help, I tried to run repair broken packages but that didnt fix the problem nothing updated,

Solution found for failed Kodi install on 18.4.1 I ran the auto remove command in terminal to get rid of any kodi files then reinstalled kodi 17.6 from the ubuntu repo, success , thanks for all your help, don't know why I didn't try this before old age is creeping up on me.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)