Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
External Seagate USB
#1
Hello all
I can't seem to delete, rename, move etc files frome my external Seagate 1TB USB drive getting an input/output error.  If I go into a sub folder on the external drive I can do all these things (delete, move rename ETC) from there. The external USB drive is formatted as NTFS. Does any one have any idea where I can start to troubleshoot this?  I don't think permissions are a concern in a NTFS drive, right? I am running Linux Mint 19.3 on a Lenovo T430 laptop.  I haven't had this problem until recently, like a couple of days.
Thanks:
Rich
Reply
#2
Linux and NTFS don't really work the best. Since NTFS was designed for Windows and Linux and Windows permissions are very different, you can have weird issues there. I highly recommend not doing much work with files with NTFS on a Linux system because you can have weird issues with it. If you want to use a drive to access files from Linux and Windows, I would recommend installing the exfat-fuse package on your Linux mint machine to give it the ability to work with an exfat file system and use that instead. You'll have better luck that way.

If you are not using the drive with Windows, format the drive with ext4. This way you have native support with Linux on the drive.
Reply
#3
[SOLVED] well, I Used  a relatives windows 10 machine and ran in the cmd "chkdsk /f /r /x" and everything on my Seagate Expansion drive was fixed.  I can use it fully now.  So easy. Took about 4 hrs to complete on a 1TB external USB HDD.  Tried all sort of things in Mint 19.3 but nothing worked.  I guess only Windows can fix NTFS corrupted drives.

Thanks to all.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)