Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Very low battery duration in my laptop
#1
Hello there,

A few weeks ago, I decided to move to Ubuntu 18.04 from Windows 8. And I have a lot of problems with the duration of my battery, it only has power for 20 minutes without being plug in.

I think that it is due to the graphic card use, so I installed tlp but the problem persists. My laptop is a MSI GP60 2PE Leopard.

Does anyone know a solution?

Thanks in advance!
Reply
#2
Several items:

1) Did you install the Nvidia drivers?  If so visit the "Nvidia X Server Settings".  Then under "GPU O..." look for "PowerMizer" and put "Preferred Mode" to "Auto" or "Adaptive".  You don't want it on max performance or it will always put the card at full operations and thus power usage.

2) What is your CPU doing?  Use htop, top, or GUI stats like "MATE System Monitor" to view CPU load.  Is it pegged at 100%?

3) TLP is a widely recommend program for laptops to fine tune power usage.

Code:
shell> sudo add-apt-repository ppa:linrunner/tlp
shell> sudo apt-get update
shell> sudo apt-get install tlp tlp-rdw
Jeremy (Mr. Server)

* Desktop: Ubuntu MATE
* Windows are for your walls, Apple is for your health, Linux is for your computer
Reply
#3
(08-27-2018, 08:50 PM)cleverwise Wrote: Several items:

1) Did you install the Nvidia drivers?  If so visit the "Nvidia X Server Settings".  Then under "GPU O..." look for "PowerMizer" and put "Preferred Mode" to "Auto" or "Adaptive".  You don't want it on max performance or it will always put the card at full operations and thus power usage.

2) What is your CPU doing?  Use htop, top, or GUI stats like "MATE System Monitor" to view CPU load.  Is it pegged at 100%?

3) TLP is a widely recommend program for laptops to fine tune power usage.

Code:
shell> sudo add-apt-repository ppa:linrunner/tlp
shell> sudo apt-get update
shell> sudo apt-get install tlp tlp-rdw

Thanks mate!

Let me answer:

1) I updated my driver from nvidia-340 to 390. I checked the Nvidia X Server Settings but already was in auto mode.

2) Everything seems normal in htop.

3) Already used tlp and nothing changes when I start battery mode from terminal.

The problem persists. Also, my battery never reaches full charge and in power settings the time until fully charged is changing from 14 minutes to 21 minutes to 14 hours to random number constantly. I am starting to think that my battery cracked Huh
Reply
#4
TLP usually does it for most cases although some tweaking can get better battery life.  Still just installing TLP and running the default profile is widely reported to greatly help.

It sounds like you might need a new battery.
Jeremy (Mr. Server)

* Desktop: Ubuntu MATE
* Windows are for your walls, Apple is for your health, Linux is for your computer
Reply
#5
check that you've got the 'sensors' module installed, in your system,
as this will give a better idea of what your machine is really doing.

run the Terminal Command 'inxi -F' to see what your battery & sensors module(s) are saying.

if you are running the Cinnamon version of LinuxMint,
then R/click on the Battery Icon that is on the Taskbar,& that should give some information on the Battery,
- you can then click on that Battery Information, in order to get some further Battery Information, as well.
Reply


Forum Jump:


Users browsing this thread: 2 Guest(s)