Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Audio pops when starting or changing audio applications
#1
Greetings,

I am doing audio editing using an outboard audio IO via USB.  Each time an application opens that using this, an audible "snap" is heard.  I don't know if this is caused by a sudden change in digital clocking (i.e when sampling rate is changed) or its because each time the unit is initialized for use.

Anyone else have such issue and can shed some light on this?

Thank you so very much,
-Steve
Reply
#2
It could be the audio power saving issue.  This is command

Open the following file:

/etc/modprobe.d/alsa-base.conf
Comment out:

options snd-hda-intel power_save=10


So:

#options snd-hda-intel power_save=10

Then save and close file.  Restart system.  Does it stop?
Jeremy (Mr. Server)

* Desktop: Ubuntu MATE
* Windows are for your walls, Apple is for your health, Linux is for your computer
Reply
#3
(05-21-2020, 04:00 PM)cleverwise Wrote: It could be the audio power saving issue.  This is command

Open the following file:

/etc/modprobe.d/alsa-base.conf
Comment out:

options snd-hda-intel power_save=10


So:

#options snd-hda-intel power_save=10

Then save and close file.  Restart system.  Does it stop?
Hi Cleverwise,

Thank you for your response.  I looked into that file.  I don't see that line.  If you don't mind please, I attached a text file with the Options section for your review.

Thank you so very much for your help.

-Steve


Attached Files
.txt   asla_config_setup.txt (Size: 506 bytes / Downloads: 3)
Reply
#4
Check the power saving status:

In the shell issue:

Code:
cat /sys/module/snd_hda_intel/parameters/power_save

If you get an one back change it temporary to zero.

Code:
echo "0" | sudo tee /sys/module/snd_hda_intel/parameters/power_save
Jeremy (Mr. Server)

* Desktop: Ubuntu MATE
* Windows are for your walls, Apple is for your health, Linux is for your computer
Reply
#5
(05-22-2020, 01:04 PM)cleverwise Wrote: Check the power saving status:

In the shell issue:

Code:
cat /sys/module/snd_hda_intel/parameters/power_save

If you get an one back change it temporary to zero.

Code:
echo "0" | sudo tee /sys/module/snd_hda_intel/parameters/power_save
Using that command I got back a zero.

-Steve
Reply
#6
Okay.

Well let's check the power save controller file.

Code:
cat /sys/module/snd_hda_intel/parameters/power_save_controller

What do you get?
Jeremy (Mr. Server)

* Desktop: Ubuntu MATE
* Windows are for your walls, Apple is for your health, Linux is for your computer
Reply
#7
(05-23-2020, 11:43 AM)cleverwise Wrote: Okay.

Well let's check the power save controller file.

Code:
cat /sys/module/snd_hda_intel/parameters/power_save_controller

What do you get?
With that command, it returned a Y.
Reply
#8
Then power save is still on.

Try the following (won't survive a reboot)

Code:
echo "0" | sudo tee /sys/module/snd_hda_intel/parameters/power_save_controller

After that does the popping stop?
Jeremy (Mr. Server)

* Desktop: Ubuntu MATE
* Windows are for your walls, Apple is for your health, Linux is for your computer
Reply
#9
(05-23-2020, 09:24 PM)cleverwise Wrote: Then power save is still on.

Try the following (won't survive a reboot)

Code:
echo "0" | sudo tee /sys/module/snd_hda_intel/parameters/power_save_controller

After that does the popping stop?
I tried that command.  Did not change my experience.  Even though all audio software does this on startup, the worst offender is Audacity.  Every time I open that up, my usb audio io goes nuts for a couple seconds, then settles down.  I suspect this is not a power issue, but rather audio artifacts of sample rate, bit depth, and clocking settings that get changed, re-initialized, etc., when a piece of software takes control of the device.  I just don't know how to prove it.

-Steve
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)