Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Ubuntu Server for Raspberry Pi HDMI Problem
#1
So my installation of Ubuntu MATE 18.04 for my Raspberry Pi 3B stopped being able to boot the other day, so I decided to install the new image file of Ubuntu Server 20.04 for the Raspberry Pi and used Wimpy's desktopify script to put the MATE desktop on it. It is working fine when displayed on my TV. When I plug it into my monitor, though, I get a garbled mess that I will take a photo of and put as an attatchment.

I tried a couple of things, like putting hdmi_force_hotplug=1 into config.txt, but still nothing. I also hooked it up to the official Raspberry Pi Touchscreen and it works fine. To make sure it wasn't the monitor, I inserted an SD card with Retropie loaded on it, and that worked just fine. I don't know what is going on and a quick google didn't get me anywhere.


Attached Files
.jpg   Lightdm with Onscreen Keyboard Enabled.jpg (Size: 273.61 KB / Downloads: 6)
.jpg   Systemd Boot 1.jpg (Size: 210.87 KB / Downloads: 7)
.jpg   Systemd Boot 2.jpg (Size: 172.55 KB / Downloads: 5)
Reply
#2
Well a few things come to mind.

1) Have you tried a different cable? This probably isn't the issue but I have seen odd things with HDMI cables.  My current TV has cables it likes and cables it is doesn't.  Go figure.

2) You could see if adding the following variable works:

hdmi_drive=2

3) Some power supplies can cause odd issues.  Are you using the official Pi one or an off brand?
Jeremy (Mr. Server)

* Desktop: Ubuntu MATE
* Windows are for your walls, Apple is for your health, Linux is for your computer
Reply
#3
1. The first boot with another HDMI cable things were fine. I switched HDMI cables to the one I was using after that, and once again, things looked fine. All boots afterward had the same result I had before.

2. Putting hdmi_drive=2 in config.txt didn't work.

3. It is a off brand, but it worked before on Ubuntu MATE 18.04 before it stopped being able to boot.

EDIT: Tried it again with 2 other power supplies, a phone charger and another power supply that powers another pi running a home file share. Neither of which are the official power supply, but both do their job. Neither of those fixed the issue.
Reply
#4
Okay.

Well try the following:

hdmi_safe=1

However comment out:

hdmi_drive=2
hdmi_force_hotplug=1

So:

hdmi_safe=1
#hdmi_drive=2
#hdmi_force_hotplug=1

Save and reboot.

What happens?
Jeremy (Mr. Server)

* Desktop: Ubuntu MATE
* Windows are for your walls, Apple is for your health, Linux is for your computer
Reply
#5
That works, but the resolution is 640x480, where my monitor's native resolution is 1336x768. I can't change the resolution in the display settings, but I never have on the Raspberry Pi. I would usually run the raspi-config command, but that doesn't seem to be installed. I'm not sure what to do with this.
Reply
#6
You can try adding:

hdmi_group=2
hdmi_mode=39

However I can't remember if hdmi_safe disables that option.  My current Pi is down at the moment.  I am waiting for a new microSD to USB adapter.  Then I'll have my Pi 4 online.
Jeremy (Mr. Server)

* Desktop: Ubuntu MATE
* Windows are for your walls, Apple is for your health, Linux is for your computer
Reply
#7
Nope, still have 640x480. To give you an update, here is my current config.txt:

Code:
# Please DO NOT modify this file; if you need to modify the boot config, the
# "usercfg.txt" file is the place to include user changes. Please refer to
# the README file for a description of the various configuration files on
# the boot partition.

# The unusual ordering below is deliberate; older firmwares (in particular the
# version initially shipped with bionic) don't understand the conditional
# [sections] below and simply ignore them. The Pi4 doesn't boot at all with
# firmwares this old so it's safe to place at the top. Of the Pi2 and Pi3, the
# Pi3 uboot happens to work happily on the Pi2, so it needs to go at the bottom
# to support old firmwares.

[pi4]
kernel=uboot_rpi_4_32b.bin
max_framebuffers=2

[pi2]
kernel=uboot_rpi_2.bin

[pi3]
kernel=uboot_rpi_3_32b.bin

[all]
device_tree_address=0x03000000

# The following settings are "defaults" expected to be overridden by the
# included configuration. The only reason they are included is, again, to
# support old firmwares which don't understand the "include" command.

enable_uart=1
cmdline=nobtcmd.txt

include syscfg.txt
include usercfg.txt

#hdmi_force_hotplug=1
#hdmi_drive=2
hdmi_safe=1

hdmi_group=2
hdmi_mode=39
Reply
#8
I've tried some things, and I managed to get it working.

First I tried using the official Raspberry Pi Imager to re-image Ubuntu to the SD card. This got me the same results as I did before, so I added hdmi_safe=1 to config.txt. Once again, fixed the garbled screen, but everything being at a low resolution.

Then I tried replacing hdmi_safe=1 with hdmi_group=2 and hdmi_mode=39. Everything seems to be displaying properly now at the command line.

EDIT:
Now that it has a desktop, I can confirm that yes it works!
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)