Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Guest Installation Issues with Virtualbox
#1
Yet another Virtualbox issue, that will probably remain as unanswered as the rest of my Virtualbox questions.  It seems that I just don't know how to ask a question about Linux correctly.

I've installed 8 guest VMs now on a Linux Mint 19.2 host machine.  My machine is an HP Pavilion G6 -2231DX.

I've installed Windows 7 Pro, Ubuntu 18.04.3 LTS, Zorin OS Core, Debian Jessie, Manjaro 18.1.15 XFCE, Slacko64 6.3.2, Lubunto 19.10, Ubunto Mate 18.04.01, and Linux Mint Debian edition.

All of the installations, with a few minor issues went just fine.  But two of them, Slacko64 and the latest I've tried, Linux Mint Debian Edition 3, are doing the same thing.

They are both installing initially as Live editions, that is, they are running off of the DVD, or, in a virtual machine instance, the .iso file, and are not installing to the .vdi hard drive.

I double-click on the DVD icon on the desktop to do a complete install, and get as far as the screen that asks for the language.  I double-click on English, try enter, try Tab, and I can't get it to advance to the next page.

To me, it sounds like the installer program for Slacko64 and Linux Mint Debian Edition are not compatible with Oracle's Virtualbox.

Any suggestions?

-Mike
Reply
#2
Quote:I double-click on the DVD icon on the desktop to do a complete install

I am unclear as to what you are doing. To install virtual machines in Virtual Box you don't click on a DVD on your desktop; you put the .iso file in the virtual cdrom in the "settings" panel and then click on "start" to install the operating system.

Richard
Reply
#3
This may be of help.. https://www.youtube.com/watch?v=sB_5fqiysi4

I've been using Virtualbox for many years in both Windoze and Linux...at the moment I have three Virtual Machines...Win 7...Linux Lite and Xubuntu.

I give my VM's 4GB of Ram each as I have 16GB of Ram installed...I allocate 50GB of space of my 500Gb SSD to each VM...hope this helps. [Image: smileys-thumbs-315757.gif]
Linux Forever...Windoze Never       [Image: t12701.gif]
Reply
#4
(02-13-2020, 12:27 AM)Richard Wrote:
Quote:I double-click on the DVD icon on the desktop to do a complete install

I am unclear as to what you are doing. To install virtual machines in Virtual Box you don't click on a DVD on your desktop; you put the .iso file in the virtual cdrom in the "settings" panel and then click on "start" to install the operating system.

Richard

He is saying when he is in the vm that the live enviroment shows a dvd on the desktop just as it would on bare metal and that is what he is clicking on.

I double-click on English, try enter, try Tab, and I can't get it to advance to the next page.

I find that sometimes you just have to wait even when it seems you shouldn't need to, just go get a soda or something and come back and see if it has moved.
Reply
#5
Thank you, Spudnuts,

That is exactly what I'm saying.

It's just so hard for me to explain something in Linux, since it is so different than the Windows I'm used to.  Then, the next layer is Virtualbox.  Yet another layer of abstraction.

When I installed Linux Mint 19.1, I think, Cinnamon on my laptop, it acted the same way as it is now, when I try and install it on my Virtualbox in my Linux Mint host.  It first boots into what I think is called the "Live" ( I see above, you're calling it a live environment install) install, that is, it does not ask for language, username or password, and, I assume does not even create a linux file system.  It is just a platform to launch the full installation which you initiate by double-clicking on the DVD icon on the desktop of the "Live" install.

I am just now checking if there is any system files installed on my virtual hard disk, the .vdi files, but, regretfully, I don't know enough Linux to confirm. I know lsblk, and I can see the sda hard disk file, but, I don't know how to check and see if there are any folders in that file. I don't want to mess with mount and unmount at this point.

With me so far?  I don't know any other way to explain it.  But, I'm almost certain at this point, that the file system is not created on the virtual hard drive, the .vdi file.  For that, you have to double-click on the DVD icon, which is labeled "Install Linux Mint".  That is where the full installation file is stored.  I think.

But, after doing this, initiating the full Linux install, or the full install of Linux Mint Debian Edition 3 Cinnamon, as you always seem to have to specify in Linux, all it displays is the language screen, which is part of the installation prompts.  I try to double-click on English, press Enter, Tab.....it just stays there and I never get another screen.

I have tried walking away for ten minutes.  I guess I could try overnight.
I've been waiting about an hour. I can scroll up and down the list of languages. I see at the top, it says "LMDE 3 (cindy) Installer". I can click down in the taskbar and collapse the installer window and bring it back up. I just can't get a reaction from choosing the language.

On more thing.  I've tried, as the template?, both Debian 64-bit, and Ubuntu 64-bit, and get the same result.

-Mike

bob777,

I only have 4 GB of memory on my laptop, so I give every virtual machine about 1.5 GB of memory.

With this latest virtual machine, Linux Mint Debian Edition, I just checked, I gave it about 34 GB.

Oh, I followed your link. I've already watched all of Joe Collins' Virtualbox videos. They are very good, but, I'm still stuck. Waiting right now, as Spudnuts suggested.

I'm wondering if my screen is truncated on the right side, if there isn't something I'm not seeing.

-Mike
Reply
#6
If you only have 4GB of Ram...I would install only one VM and give it 2GB of Ram.  The size of the VM all depends on the size of your HDD/SSD.  Smile

I have a 500GB SSD...so I can give my VMs 50GB of space.  When I install a Distro from the ISO...I never double click English as it's already selected...I click...Install...maybe this might be the problem.  [Image: smileys-confused-389931.gif]
Linux Forever...Windoze Never       [Image: t12701.gif]
Reply
#7
Quote: I try to double-click on English, press Enter, Tab.....it just stays there and I never get another screen.
I experience a similar (or the same) problem when I load an Ubuntu virtual machine, if I try to change to a Spanish keyboard. The window that pops up is truncated on the right, and there seems to be no way to increase the borders of the window that contains it. I have learned to just accept the default, install Ubuntu, and change the keyboard after it is installed.

Richard
Reply
#8
(02-14-2020, 05:52 AM)CodeSchlocker Wrote: Thank you, Spudnuts,

That is exactly what I'm saying.

It's just so hard for me to explain something in Linux, since it is so different than the Windows I'm used to.  Then, the next layer is Virtualbox.  Yet another layer of abstraction.

When I installed Linux Mint 19.1, I think, Cinnamon on my laptop, it acted the same way as it is now, when I try and install it on my Virtualbox in my Linux Mint host.  It first boots into what I think is called the "Live" ( I see above, you're calling it a live environment install)  install, that is, it does not ask for language, username or password, and, I assume does not even create a linux file system.  It is just a platform to launch the full installation which you initiate by double-clicking on the DVD icon on the desktop of the "Live" install.

I am just now checking if there is any system files installed on my virtual hard disk, the .vdi files, but, regretfully, I don't know enough Linux to confirm.  I know lsblk, and I can see the sda hard disk file, but, I don't know how to check and see if there are any folders in that file.  I don't want to mess with mount and unmount at this point.

With me so far?  I don't know any other way to explain it.  But, I'm almost certain at this point, that the file system is not created on the virtual hard drive, the .vdi file.  For that, you have to double-click on the DVD icon, which is labeled "Install Linux Mint".  That is where the full installation file is stored.  I think.

But, after doing this, initiating the full Linux install, or the full install of Linux Mint Debian Edition 3 Cinnamon, as you always seem to have to specify in Linux, all it displays is the language screen, which is part of the installation prompts.  I try to double-click on English, press Enter, Tab.....it just stays there and I never get another screen.

I have tried walking away for ten minutes.  I guess I could try overnight.
I've been waiting about an hour.  I can scroll up and down the list of languages.  I see at the top, it says "LMDE 3 (cindy) Installer".  I can click down in the taskbar and collapse the installer window and bring it back up.  I just can't get a reaction from choosing the language.

On more thing.  I've tried, as the template?, both Debian 64-bit, and Ubuntu 64-bit, and get the same result.

-Mike

bob777,

I only have 4 GB of memory on my laptop, so I give every virtual machine about 1.5 GB of memory.

With this latest virtual machine, Linux Mint Debian Edition, I just checked, I gave it about 34 GB.

Oh, I followed your link.  I've already watched all of Joe Collins' Virtualbox videos.  They are very good, but, I'm still stuck.  Waiting right now, as Spudnuts suggested.

I'm wondering if my screen is truncated on the right side, if there isn't something I'm not seeing.

-Mike

Yes most linux isos boot into a live enviroment which means you can use it without installing it on your computer unlike windows which will only install the os and not let you try it out before installing it, that is a what I call a dead enviroment as in no choice what to do.

To my knowledge there is no way to see the file system in a .vdi until you mount it in a vm, and considering how far you got in the install it should not have any filesystem on it yet.

Waiting 10 minutes should be more than long enough so if it didn't work then it's not going to.

Try using the tab key and see if different things become the cursor focus.

If you think the window is bigger than your monitor is set to show you can drag a window from anyspot in it by holding down the alt key while grabbing with the left mouse button to slide it around. (I use mint mate so it may be different with cinnamon, shift/ctrl/tab)

I never use more than half of my memory for a vm and if you do don't open more than one vm at a time.

One last thing I forgot to ask is if you have the extensions installed in vbox? You can check that by opening vbox and use file/preferences/extentions it should show at least 1 active extension pack in the window.(preferably that matches the version of vbox you have installed)
Reply
#9
(02-13-2020, 05:46 PM)spudnuts Wrote:
(02-13-2020, 12:27 AM)Richard Wrote:
Quote:I double-click on the DVD icon on the desktop to do a complete install

I am unclear as to what you are doing. To install virtual machines in Virtual Box you don't click on a DVD on your desktop; you put the .iso file in the virtual cdrom in the "settings" panel and then click on "start" to install the operating system.

Richard

He is saying when he is in the vm that the live enviroment shows a dvd on the desktop just as it would on bare metal and that is what he is clicking on.

I double-click on English, try enter, try Tab, and I can't get it to advance to the next page.

I find that sometimes you just have to wait even when it seems you shouldn't need to, just go get a soda or something and come back and see if it has moved.
spudnuts,

I've waited for 24 hours.  Still stuck on screen to choose language.

-Mike
Reply
#10
(02-14-2020, 06:57 PM)spudnuts Wrote:
(02-14-2020, 05:52 AM)CodeSchlocker Wrote: Thank you, Spudnuts,

That is exactly what I'm saying.

It's just so hard for me to explain something in Linux, since it is so different than the Windows I'm used to.  Then, the next layer is Virtualbox.  Yet another layer of abstraction.

When I installed Linux Mint 19.1, I think, Cinnamon on my laptop, it acted the same way as it is now, when I try and install it on my Virtualbox in my Linux Mint host.  It first boots into what I think is called the "Live" ( I see above, you're calling it a live environment install)  install, that is, it does not ask for language, username or password, and, I assume does not even create a linux file system.  It is just a platform to launch the full installation which you initiate by double-clicking on the DVD icon on the desktop of the "Live" install.

I am just now checking if there is any system files installed on my virtual hard disk, the .vdi files, but, regretfully, I don't know enough Linux to confirm.  I know lsblk, and I can see the sda hard disk file, but, I don't know how to check and see if there are any folders in that file.  I don't want to mess with mount and unmount at this point.

With me so far?  I don't know any other way to explain it.  But, I'm almost certain at this point, that the file system is not created on the virtual hard drive, the .vdi file.  For that, you have to double-click on the DVD icon, which is labeled "Install Linux Mint".  That is where the full installation file is stored.  I think.

But, after doing this, initiating the full Linux install, or the full install of Linux Mint Debian Edition 3 Cinnamon, as you always seem to have to specify in Linux, all it displays is the language screen, which is part of the installation prompts.  I try to double-click on English, press Enter, Tab.....it just stays there and I never get another screen.

I have tried walking away for ten minutes.  I guess I could try overnight.
I've been waiting about an hour.  I can scroll up and down the list of languages.  I see at the top, it says "LMDE 3 (cindy) Installer".  I can click down in the taskbar and collapse the installer window and bring it back up.  I just can't get a reaction from choosing the language.

On more thing.  I've tried, as the template?, both Debian 64-bit, and Ubuntu 64-bit, and get the same result.

-Mike

bob777,

I only have 4 GB of memory on my laptop, so I give every virtual machine about 1.5 GB of memory.

With this latest virtual machine, Linux Mint Debian Edition, I just checked, I gave it about 34 GB.

Oh, I followed your link.  I've already watched all of Joe Collins' Virtualbox videos.  They are very good, but, I'm still stuck.  Waiting right now, as Spudnuts suggested.

I'm wondering if my screen is truncated on the right side, if there isn't something I'm not seeing.

-Mike

Yes most linux isos boot into a live enviroment which means you can use it without installing it on your computer unlike windows which will only install the os and not let you try it out before installing it, that is a what I call a dead enviroment as in no choice what to do.

To my knowledge there is no way to see the file system in a .vdi until you mount it in a vm, and considering how far you got in the install it should not have any filesystem on it yet.

Waiting 10 minutes should be more than long enough so if it didn't work then it's not going to.

Try using the tab key and see if different things become the cursor focus.

If you think the window is bigger than your monitor is set to show you can drag a window from anyspot in it by holding down the alt key while grabbing with the left mouse button to slide it around. (I use mint mate so it may be different with cinnamon, shift/ctrl/tab)

I never use more than half of my memory for a vm and if you do don't open more than one vm at a time.

One last thing I forgot to ask is if you have the extensions installed in vbox? You can check that by opening vbox and use file/preferences/extentions it should show at least 1 active extension pack in the window.(preferably that matches the version of vbox you have installed)



Yes, I have  Oracle VM VirtualBox Extension Pack Version 6.1.2r135662, which, since I have VirtualBox 6.1.2 installed on my Linux Mint host, should be correct.

I just tried downloading the .iso file for LMDE 3 again, same thing.  I even deleted my old LMDE 3 VM and started the settings from scratch.  I think I'll try LMDE2.  Maybe I'll have better luck with that installer program.  For right now, it really seems, that there in an incompatibility between the installer program for LMDE 3 and virtualbox.  I also have this problem trying to install Slacko64 as a VM.  Only those two distros so far have given me this problem.

As far as memory, I'm giving my LMDE 3 VM around 1.5 GB out of my 4GBs of my machine's memory.  This seems to work for every other distro.

Oh, thank you for sticking with me. 

-Mike

(02-15-2020, 07:56 PM)CodeSchlocker Wrote:
(02-14-2020, 06:57 PM)spudnuts Wrote:
(02-14-2020, 05:52 AM)CodeSchlocker Wrote: Thank you, Spudnuts,

That is exactly what I'm saying.

It's just so hard for me to explain something in Linux, since it is so different than the Windows I'm used to.  Then, the next layer is Virtualbox.  Yet another layer of abstraction.

When I installed Linux Mint 19.1, I think, Cinnamon on my laptop, it acted the same way as it is now, when I try and install it on my Virtualbox in my Linux Mint host.  It first boots into what I think is called the "Live" ( I see above, you're calling it a live environment install)  install, that is, it does not ask for language, username or password, and, I assume does not even create a linux file system.  It is just a platform to launch the full installation which you initiate by double-clicking on the DVD icon on the desktop of the "Live" install.

I am just now checking if there is any system files installed on my virtual hard disk, the .vdi files, but, regretfully, I don't know enough Linux to confirm.  I know lsblk, and I can see the sda hard disk file, but, I don't know how to check and see if there are any folders in that file.  I don't want to mess with mount and unmount at this point.

With me so far?  I don't know any other way to explain it.  But, I'm almost certain at this point, that the file system is not created on the virtual hard drive, the .vdi file.  For that, you have to double-click on the DVD icon, which is labeled "Install Linux Mint".  That is where the full installation file is stored.  I think.

But, after doing this, initiating the full Linux install, or the full install of Linux Mint Debian Edition 3 Cinnamon, as you always seem to have to specify in Linux, all it displays is the language screen, which is part of the installation prompts.  I try to double-click on English, press Enter, Tab.....it just stays there and I never get another screen.

I have tried walking away for ten minutes.  I guess I could try overnight.
I've been waiting about an hour.  I can scroll up and down the list of languages.  I see at the top, it says "LMDE 3 (cindy) Installer".  I can click down in the taskbar and collapse the installer window and bring it back up.  I just can't get a reaction from choosing the language.

On more thing.  I've tried, as the template?, both Debian 64-bit, and Ubuntu 64-bit, and get the same result.

-Mike

bob777,

I only have 4 GB of memory on my laptop, so I give every virtual machine about 1.5 GB of memory.

With this latest virtual machine, Linux Mint Debian Edition, I just checked, I gave it about 34 GB.

Oh, I followed your link.  I've already watched all of Joe Collins' Virtualbox videos.  They are very good, but, I'm still stuck.  Waiting right now, as Spudnuts suggested.

I'm wondering if my screen is truncated on the right side, if there isn't something I'm not seeing.

-Mike

Yes most linux isos boot into a live enviroment which means you can use it without installing it on your computer unlike windows which will only install the os and not let you try it out before installing it, that is a what I call a dead enviroment as in no choice what to do.

To my knowledge there is no way to see the file system in a .vdi until you mount it in a vm, and considering how far you got in the install it should not have any filesystem on it yet.

Waiting 10 minutes should be more than long enough so if it didn't work then it's not going to.

Try using the tab key and see if different things become the cursor focus.

If you think the window is bigger than your monitor is set to show you can drag a window from anyspot in it by holding down the alt key while grabbing with the left mouse button to slide it around. (I use mint mate so it may be different with cinnamon, shift/ctrl/tab)

I never use more than half of my memory for a vm and if you do don't open more than one vm at a time.

One last thing I forgot to ask is if you have the extensions installed in vbox? You can check that by opening vbox and use file/preferences/extentions it should show at least 1 active extension pack in the window.(preferably that matches the version of vbox you have installed)



Yes, I have  Oracle VM VirtualBox Extension Pack Version 6.1.2r135662, which, since I have VirtualBox 6.1.2 installed on my Linux Mint host, should be correct.

I just tried downloading the .iso file for LMDE 3 again, same thing.  I even deleted my old LMDE 3 VM and started the settings from scratch.  I think I'll try LMDE2.  Maybe I'll have better luck with that installer program.  For right now, it really seems, that there in an incompatibility between the installer program for LMDE 3 and virtualbox.  I also have this problem trying to install Slacko64 as a VM.  Only those two distros so far have given me this problem.

As far as memory, I'm giving my LMDE 3 VM around 1.5 GB out of my 4GBs of my machine's memory.  This seems to work for every other distro.

Oh, thank you for sticking with me. 

-Mike
  
One more thing.  Is there another way to install a this kind of a distro without booting into a live environment and double-clicking the "Install Linux Mint" DVD icon?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)