Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ZIP anomaly
#1
Any one know why I get an extra .ZIP file, (see screenshot attachment), when ever I try to compress a folder? It doesn't happen every time but it's there no matter which compression method I use IE ZIP 7z Tar.gz ETC. This in effect doubles the the size of my compressed file. If I open the ".Zip" file, in it is what I originally wanted to compress. I can of course delete the contained ".Zip" file and reduce the compressed file I'm trying to make. Tried doing it via terminal and sometimes that method would not even create a compressed file at all and sometimes it would. Maybe I'm doing something wrong? Any one else having this problem?
Maybe a bug?
I'm running:
Linux Mint Mate 19.1
Lenovo T430 Laptop
8 Gigs RAM
180 GB Intel SSD


Attached Files
.png   Another .zip file.png (Size: 68.8 KB / Downloads: 13)
Reply
#2
I tried making a number of compressed folders, was not able to reproduce the error... using only the defaults

Debian Mate Testing
Reply
#3
(10-21-2019, 05:11 PM)rjs1943 Wrote: ried doing it via terminal and sometimes that method would not even create a compressed file at all and sometimes it would.

Have you used the correct commands? Try the following, they should work.

Creating a tar.gz archive:
Code:
tar czvf archive.tar.gz file1 file2 file3

Creating a zip archive:
Code:
zip -r archive.zip file1 file2 file3
My website - My git repos

"Things are only impossible until they’re not." - Captain Jean-Luc Picard
Reply
#4
Yes I made sure all commands were correct using the terminal method.  Most of the problems are using the GUI method.  I'm going to try using my live USB or put Mint in a virtual box and see if there is something wrong with my specific installation on my computer.  I'll get back here and let you know what happens later. For the most part I don't use Zip that often but it is nice if I have to email or transfer large Folders/Files ETC.

Thank you for you reply's .
Reply
#5
Smile 
OK I tried using the Live USB stick (Mint 19.1 MATE) and tried using Zip and got the same results no matter which folder I tried to compress.  I tried compressing a folder from the running USB stick and from the computer SSD, same results.  Maybe I'll download another ISO file from Linux Mint both 19.1 and 19.2 and see what happens.  I have 19.2 mint mate on another USB stick, I think I'll try that one next, stay tuned.

Fun isn't it? [Image: smile.png]

Tried using 19.2 Live USB and I am getting the same results no matter which folder I try to compress.  Seems to be some what better if I open said folder, select all, and then compress the folder that way.  Still having problems compressing folders via terminal.  Sometimes it works and other times it doesn't even make a compressed folder no matter which folder I choose.  It's not a big deal as I don't compress that often.  I'm just curious as to why this is happening.  Maybe a bug, maybe my laptop, who knows.

Thank you all for helping.
Reply
#6
Here is some more info for all that's interested:

 I un-installed (complete removal) and re-installed via synaptic package manager "unace rar unrar unar p7zip-rar p7zip zip unzip"

 I removed (complete removal) engrampa archive manager and re-installed engrampa also via Synaptic Package manager.


The following is the very first error I got when I tried Zip command using Terminal:
"zip warning: name not matched” while compressing a directory, I was sometimes getting when compressing folders via Terminal.

Entering following in command line:

[zip -r Whatever folder.zip Whatever folder]. or pressing TAB to enter the folder.
Then pressing enter. Sometimes it works and sometimes it doesn't.

Anything else I should be doing?
Reply
#7
I made a fresh install of Linux Mint Mate 19.1
after reboot I did nothing other than update using the Mint Updater
then I copied my .mozilla and Downloads folders from my Debian system (same drive).
I Did Not activate Timeshift

I was not able to replicate your error...

... using only the Mate GUI
I did not try from the terminal.

Perhaps something you have installed has created a conflict.
Reply
#8
Well everyone, I found out what was happening.  Using zip via the terminal, somehow I zipped up some folders without giving it a name and there was a ".zip" files in the folder I was trying to zip.  Only thing being a ".zip" file it was a hidden ".zip" file and wasn't showing up in file manager, but it would showing up in the zipped folder using archive manager.  I used crytl>H keyboard shortcut to find the ".zip" file.

Anyway thanks to all for your info and help, it is appreciated.

By putting in the command zip -r STAGING\ IDEAS/.zip STAGING\ IDEAS/, the slash between IDEAS and .zip was the culprit from what I understand.
Reply
#9
wow! Glad you figured it out.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)