Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
IP Address Confusion [SOLVED]
#21
Well, it did something, but not what we want. Both wlan0 and eth0 have 192.168.0.29, which I assume is not a good thing.
Code:
$ ifconfig
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
       inet 192.168.0.29  netmask 255.255.255.0  broadcast 192.168.0.255
       inet6 fd00:688f:2e75:1932:ba27:ebff:feb8:1b2  prefixlen 64  scopeid 0x0<global>
       inet6 2604:2d80:d40f:d600:ba27:ebff:feb8:1b2  prefixlen 64  scopeid 0x0<global>
       inet6 fe80::ba27:ebff:feb8:1b2  prefixlen 64  scopeid 0x20<link>
       ether b8:27:eb:b8:01:b2  txqueuelen 1000  (Ethernet)
       RX packets 280  bytes 30139 (29.4 KiB)
       RX errors 0  dropped 0  overruns 0  frame 0
       TX packets 191  bytes 27463 (26.8 KiB)
       TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
       inet 127.0.0.1  netmask 255.0.0.0
       inet6 ::1  prefixlen 128  scopeid 0x10<host>
       loop  txqueuelen 1000  (Local Loopback)
       RX packets 13  bytes 764 (764.0 B)
       RX errors 0  dropped 0  overruns 0  frame 0
       TX packets 13  bytes 764 (764.0 B)
       TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
       inet 192.168.0.29  netmask 255.255.255.0  broadcast 192.168.0.255
       inet6 2604:2d80:d40f:d600:ba27:ebff:feed:54e7  prefixlen 64  scopeid 0x0<global>
       inet6 fd00:688f:2e75:1932:ba27:ebff:feed:54e7  prefixlen 64  scopeid 0x0<global>
       inet6 fe80::ba27:ebff:feed:54e7  prefixlen 64  scopeid 0x20<link>
       ether b8:27:eb:ed:54:e7  txqueuelen 1000  (Ethernet)
       RX packets 103  bytes 16040 (15.6 KiB)
       RX errors 0  dropped 0  overruns 0  frame 0
       TX packets 57  bytes 11924 (11.6 KiB)
       TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
$ cat /etc/dhcpcd.conf
A sample configuration for dhcpcd.
# See dhcpcd.conf(5) for details.

# Allow users of this group to interact with dhcpcd via the control socket.
#controlgroup wheel

# Inform the DHCP server of our hostname for DDNS.
hostname

# Use the hardware address of the interface for the Client ID.
clientid
# or
# Use the same DUID + IAID as set in DHCPv6 for DHCPv4 ClientID as per RFC4361.
# Some non-RFC compliant DHCP servers do not reply with this set.
# In this case, comment out duid and enable clientid above.
#duid

# Persist interface configuration when dhcpcd exits.
persistent

# Rapid commit support.
# Safe to enable by default because it requires the equivalent option set
# on the server to actually work.
option rapid_commit

# A list of options to request from the DHCP server.
option domain_name_servers, domain_name, domain_search, host_name
option classless_static_routes
# Respect the network MTU. This is applied to DHCP routes.
option interface_mtu

# Most distributions have NTP support.
#option ntp_servers

# A ServerID is required by RFC2131.
require dhcp_server_identifier

# Generate SLAAC address using the Hardware Address of the interface
#slaac hwaddr
# OR generate Stable Private IPv6 Addresses based from the DUID
slaac private

# Example static IP configuration:
#interface eth0
#static ip_address=192.168.0.10/24
#static ip6_address=fd51:42f8:caae:d92e::ff/64
#static routers=192.168.0.1
#static domain_name_servers=192.168.0.1 8.8.8.8 fd51:42f8:caae:d92e::1

# It is possible to fall back to a static IP if DHCP fails:
# define static profile
#profile static_eth0
#static ip_address=192.168.1.23/24
#static routers=192.168.1.1
#static domain_name_servers=192.168.1.1

# fallback to static profile on eth0
#interface eth0
#fallback static_eth0

interface eth0
clientid b8:27:eb:b8:01:b2
static ip_address=192.168.0.29/24
noipv6

interface wlan0
clientid b8:27:eb:ed:54:e7
static ip=192.168.0.30/24
noipv6

$
Just a teen who LOVES working with computers
Reply
#22
Recheck your wlan entry in the conf file you put in static ip instead of static ip_address
Reply
#23
Scrap that. After looking at my last post I noticed that I didn't include the _address for the wlan0 interface. Updated that and it works!!!

Code:
$ ifconfig
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
       inet 192.168.0.29  netmask 255.255.255.0  broadcast 192.168.0.255
       inet6 fd00:688f:2e75:1932:ba27:ebff:feb8:1b2  prefixlen 64  scopeid 0x0<global>
       inet6 2604:2d80:d40f:d600:ba27:ebff:feb8:1b2  prefixlen 64  scopeid 0x0<global>
       inet6 fe80::ba27:ebff:feb8:1b2  prefixlen 64  scopeid 0x20<link>
       ether b8:27:eb:b8:01:b2  txqueuelen 1000  (Ethernet)
       RX packets 321  bytes 30748 (30.0 KiB)
       RX errors 0  dropped 0  overruns 0  frame 0
       TX packets 200  bytes 28533 (27.8 KiB)
       TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
       inet 127.0.0.1  netmask 255.0.0.0
       inet6 ::1  prefixlen 128  scopeid 0x10<host>
       loop  txqueuelen 1000  (Local Loopback)
       RX packets 13  bytes 764 (764.0 B)
       RX errors 0  dropped 0  overruns 0  frame 0
       TX packets 13  bytes 764 (764.0 B)
       TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
       inet 192.168.0.30  netmask 255.255.255.0  broadcast 192.168.0.255
       inet6 2604:2d80:d40f:d600:ba27:ebff:feed:54e7  prefixlen 64  scopeid 0x0<global>
       inet6 fd00:688f:2e75:1932:ba27:ebff:feed:54e7  prefixlen 64  scopeid 0x0<global>
       inet6 fe80::ba27:ebff:feed:54e7  prefixlen 64  scopeid 0x20<link>
       ether b8:27:eb:ed:54:e7  txqueuelen 1000  (Ethernet)
       RX packets 147  bytes 11599 (11.3 KiB)
       RX errors 0  dropped 0  overruns 0  frame 0
       TX packets 58  bytes 11735 (11.4 KiB)
       TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
$


Thanks!!!
Just a teen who LOVES working with computers
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)