Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
lost Internet connection in virtual Arch (SOLVED)
Here's a network connectivity problem:

I installed a new headless Arch virtual machine yesterday in Oracle VBox. At some point, around the time I added myself as a user, and added myself to the sudoers file, I lost Internet access. When I ping I get this message: "ping: Temporary failure in name resolution"

Except, of course, it's not temporary.

I feel I should point out that message does not say you have no connection to the internet but that it can not resolve the name which could be for other reasons, try to ping the ip address of google ( instead and that will tell you if the connection is gone or name server is wrong/not working.
In response to ping I get  "ping: connect: Network is unreachable"

As a test I tried both and on another Arch virtual machine and both worked fine.
Do you use NetworkManager? If yes, try to restart it, wait a few seconds and try again.

sudo systemctl restart NetworkManager

If not, then your dhcp configuration might be bad. Easiest solution: User NetworkManager.
I finally realized I forgot to enable dhcpcd
systemctl enable dhcpcd

It's almost always something stupid you have done a thousand times before and missed the last time.

Forum Jump:

Users browsing this thread: 1 Guest(s)