Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
(SOLVED) Diacritics in Mint
#1
Exclamation 
I am not sure my problem is caused by Mint.
On my other PC (Windows) the same version of WPS Office does not give me this problem.

I use Romanian diacritics: ș ț ă î â Ș Ț Ă Î Â
In my WPS Office documents, the șȘ and țȚ are not being diplayed correct.
They are bigger and without serif in the serif fonts.
Here is a screen capture.

.png   Screenshot from 2019-09-02 13-02-32.png (Size: 12.06 KB / Downloads: 5)

What should I check in Mint settings?
Wps Office forum for Linux version does not work, when I try to login I receive a coding error and I just do not know where to find help.

Ovi.
Reply
#2
(09-02-2019, 05:47 PM)ovisergiu Wrote: I am not sure my problem is caused by Mint.
On my other PC (Windows) the same version of WPS Office does not give me this problem.

I use Romanian diacritics: ș ț ă î â Ș Ț Ă Î Â
In my WPS Office documents, the șȘ and țȚ are not being diplayed correct.
They are bigger and without serif in the serif fonts.
Here is a screen capture.


What should I check in Mint settings?
Wps Office forum for Linux version does not work, when I try to login I receive a coding error and I just do not know where to find help.

Ovi.

Is your keyboard layout set for Romanian?
Jeremy (Mr. Server)

* Desktop: Ubuntu MATE
* Windows are for your walls, Apple is for your health, Linux is for your computer
Reply
#3
Thank you much for replying, Jeremy!
Yes, my keyboard is set for Romanian layout (if it would not be set for Romanian, I believe I could not type those diacritics)
I have both English and Romanian (I switch using Left ALT + Left Shift).
I also have Libre Office and this problem is not present there.
Reply
#4
(09-02-2019, 07:07 PM)ovisergiu Wrote: Thank you much for replying, Jeremy!
Yes, my keyboard is set for Romanian layout (if it would not be set for Romanian, I believe I could not type those diacritics)
I have both English and Romanian (I switch using Left ALT + Left Shift).
I also have Libre Office and this problem is not present there.

Well I admit my experience with non English languages is limited.  Still I have had to installed language packs for clients.

Is the full language pack installed for Romanian?
Jeremy (Mr. Server)

* Desktop: Ubuntu MATE
* Windows are for your walls, Apple is for your health, Linux is for your computer
Reply
#5
Hi, Jeremy, thank you for replying!
I noticed in fact, that the same problem is present also in Gmail when I am writing an email with Romanian diacritics...
In fact, I believe only LibreOffice does NOT have that problem, but in the other software I encounter that problem.
Regarding the language packs, I search for „language” in Mint and I noticed Romanian was not installed. I just installed it and I have to restart my PC but momentarily I am doing something and I just can not restart it. I will come back with a message after I manage to restart it.
Reply
#6
Hi there,

I am not sure to identify the problem's source. One thing that seems possible: is something wrong with your locales? maybe?
Can you type this diacritics in your terminal? if you do:
Code:
$echo ș ț ă î â Ș Ț Ă Î Â
and press enter, do they all display correctly in the answer?

If not, hopefully it is something wrong in your locale settings. Here is a link with all sortes of details about the locales.
https://www.tecmint.com/set-system-locales-in-linux/
If it is not enough, try to see an archlinux installation guide. It is needed to manually set locale in the arch linux installation.


If it is not the locales, sadly i have no clue what can be the problem's source.
Reply
#7
Question 
Hi, Tuxinho and thank you for you reply.
After pasting the command you suggested, I got this answer:

Code:
ș: command not found
I also read that article but I do not understand what to do... but I can tell you that after my last post where I announced I installed Romanian language pack, I restarted my computer and then in keyboard layouts I could see these layouts: Romanian, Romanian (cedilla), Romanian (Germany), Romanian (Germany no dead keys), Romanian (standard), Romanian (standard cedilla), Romanian (Win Keys).
I have tried all of those but I found that only Romanian (standard) is CLOSE to what Romanian layout should be. I say that because the cedilla versions are not correct since Romanian diacritics do not have cedilla (as suggested by Romanian linguistics). I wrote „Romanian (standard) is close” because the characters/diacritic characters are not displayed correct: „ș” and „ț” are bigger than „s” and „t” and also they are non-serif in any used font (including the serif ones):
[Image: screen14.png]
Reply
#8
(09-10-2019, 01:29 PM)ovisergiu Wrote: Hi, Tuxinho and thank you for you reply.
After pasting the command you suggested, I got this answer:

Code:
ș: command not found
I also read that article but I do not understand what to do... but I can tell you that after my last post where I announced I installed Romanian language pack, I restarted my computer and then in keyboard layouts I could see these layouts: Romanian, Romanian (cedilla), Romanian (Germany), Romanian (Germany no dead keys), Romanian (standard), Romanian (standard cedilla), Romanian (Win Keys).
I have tried all of those but I found that only Romanian (standard) is CLOSE to what Romanian layout should be. I say that because the cedilla versions are not correct since Romanian diacritics do not have cedilla (as suggested by Romanian linguistics). I wrote „Romanian (standard) is close” because the characters/diacritic characters are not displayed correct: „ș” and „ț” are bigger than „s” and „t” and also they are non-serif in any used font (including the serif ones):
[Image: screen14.png]

You are using a Romanian layout keyboard, correct?
Jeremy (Mr. Server)

* Desktop: Ubuntu MATE
* Windows are for your walls, Apple is for your health, Linux is for your computer
Reply
#9
Yes I do.
Can it be the ms-corefonts problem? I have heard the linux package is dated from 1999 or the fonts come from 1999 and in that time they had this flaw I encounter.
Reply
#10
If the echo command is not working in your terminal i strongly believe  the problem is your locale. I had the same problem with the French keyboard before.
If i have to guess, i would say that during installation you selected English as a language and not Romanian. Am i right?

Before continuing, the locale is the language your linux system is set into. It works as a few variables and your system looks at this to know how it should write. It is not the best way to explain it, but it is the easiest.
Now; if, in your terminal you can not get your diacritics, i believe it your system it is not set correctly.
In my computer, in my termnal, if i type:
Code:
locale

the first line i see is:
Code:
LANG=fr_FR.UTF-8

after this is see a lot of different lines all starting with LC_ and all ending with "LANG=fr_FR.UTF-8". But the first one only is important here.
When you type the locale command, is your first line correctly displaying  LANG=ro_RO.UTF-8 ?

If not this is the problem we need to fixe.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)