Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ifconfig not avaliable with net-tools in Debian [SOLVED]
#1
I decided to try out Debian 10 today on one of my machines. I wanted to put a static IP on it in case I ever want to ssh into it. One of the things I am used to using is the ifconfig command. I installed the net-tools package and typed ifconfig into the terminal, but it still dosen't work. After a reboot it still didn't work. I tried using the which command to make sure it was installed:
Code:
$ which net-tools
$

I tried installing it again:

Code:
$ sudo apt install net-tools
[sudo] password for jeremiah:
Reading package lists... Done
Building dependency tree      
Reading state information... Done
net-tools is already the newest version (1.60+git20180626.aebd88e-1).
0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
$

I tried re-installing it, but still ifconfig won't work:

Code:
$ ifconfig
bash: ifconfig: command not found
$


What is going on? Do I need to install another package? I looked around on my own, but everything that I have found just tells me to install net-tools and it should work.

This is Debian 10 with the XFCE Desktop, if that makes any difference.
Just a teen who LOVES working with computers
Reply


Messages In This Thread
ifconfig not avaliable with net-tools in Debian [SOLVED] - by Jeremiah - 08-10-2019, 11:14 PM

Forum Jump:


Users browsing this thread: 1 Guest(s)